Orbiter-Forum  

Go Back   Orbiter-Forum > Projects > ORBITER: 2010-P1 > Bug
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter crashes when loading CargoCnt.dds Issue Tools
issueid=914 02-03-2012 10:06 AM
G422 Co-Pilot Beta
Orbiter crashes when loading CargoCnt.dds
pretty much the title

i am actually using orbiter p2 beta and i notice that it crashes when it loads a file called CargoCnt.dds

any help pls?

Issue Details
Project ORBITER: 2010-P1
Status Unconfirmed
Priority 3
Affected Version 111105
Fixed Version (none)
Users able to reproduce bug 0
Users unable to reproduce bug 2
Assigned Users (none)
Tags (none)

02-03-2012 10:56 AM
Orbiter Founder
 
Does it crash if you load a scenario without a ShuttleA instance?
Reply
02-03-2012 11:51 PM
Donator
 
I can not reproduce the issue, because I can't even get to the Overhead panel.
[CTRL][UP] should do the trick in 2D panel mode, right?

I've tried the 111105 Version with inline and D3D9Client, both no difference.
Has the Overhead panel gone?
Reply
02-14-2012 10:20 AM
G422 Co-Pilot Beta
 
for instance, in a scenario where it loads a Shuttle-A with NO CARGO....it loads just fine..
but when you start loading cargo, it crashes.

BTW the shuttle-a in 111105 has a new 2D panel, there is no overhead panel.
Reply
02-14-2012 07:51 PM
Donator
 
Hi again,
I still can't reproduce the issue, although I've tried several versions of Orbiter besides the mentioned v111105.

Can't reproduce because either
I can access the overhead-panel (e.g. v100830) and don't get a crash
or
I can not access the overhead-panel (e.g. v111105) and don't get a crash.

Can you please post exactly with what version of orbiter you a trying to run what scenario?
Helpful might be 2 scenarios, one that's running and on that's crashing.

---
P.S.: You get the version number from the LaunchPad dialog when you select "About Orbiter". There you should find something like "Build 5 Nov 2011 [v.111105]"
Reply
02-14-2012 08:22 PM
orb orb is offline
O-F Administrator
Ninja
 
I guess the affected version is the one filled in this bug report.
Reply
02-14-2012 11:00 PM
Donator
 
Quote:
Originally Posted by orb
 I guess the affected version is the one filled in this bug report.
Me too. But that's what's puzzeling me. With that version there is no access to the overhead-panel...
Can/could you (orb) reproduce this with 111105?
Reply
02-17-2012 07:26 PM
orb orb is offline
O-F Administrator
Ninja
 
Quote:
Originally Posted by kuddel
 Me too. But that's what's puzzeling me. With that version there is no access to the overhead-panel...
The CargoCnt.dds is only used in virtual cockpit mode (ShuttleA_vc.msh). There's no other reference to it in the code.

Quote:
Originally Posted by kuddel
 Can/could you (orb) reproduce this with 111105?
Sorry, I couldn't check it earlier, as I was using Linux. I can't reproduce the crash with several stock ShuttleA scenarios available in Orbiter 111105.
Reply
02-20-2012 01:19 PM
Donator
 
So this one goes to ken1029:

Could you please check if you have a "CargoCnt.dds" file under the "Textures2" Folder? This might be corrupted.
Reason: Orbiter first tries to load the textures from the Textures2 Folder (and the according sub-folders). Only if it can not found the texture there it looks in the regular "Textures" Folder.
So, please check if you have a (corrupted) file here:
Textures2\ShuttleA\CargoCnt.dds
If you have, please try to remove it (or rename it, so you have a backup)

/Kuddel
Reply
02-26-2012 03:43 AM
G422 Co-Pilot Beta
 
there is no folder named ShuttleA in the Textures2 folder. its under Textures.
Reply
02-26-2012 03:44 AM
G422 Co-Pilot Beta
 
so anyway i've switched back to version 100830 and i do not find the problem. the affected version is 111105
Reply
02-26-2012 09:58 PM
Donator
 
O.K., but it would still be interesting what happens/happened at your 111105 setup. Would you mind creating an MD5 sum of the CargoCnt.dds ? Or post/attach the file from your bogus 111105 setup?
Reply
02-27-2012 01:46 PM
orb orb is offline
O-F Administrator
Ninja
 
Quote:
Originally Posted by ken1029
 so anyway i've switched back to version 100830 and i do not find the problem. the affected version is 111105
Me and kuddel can't reproduce it in Orbiter 111105, so it can't be the version that is affected, but it could be something in your installation of this version.

Did you try to reproduce it in another, clean installation of Orbiter 111105 with the same result, before you gave up?
Reply
03-01-2012 04:14 PM
Orbinaut
 
I have had several Shuttle-A related crashes using Orbiter 2006-P1 (On loading CargoCnt.dds, on switching to cockpit mode, and on switching to VC) but I haven't had these problems in any other version. I haven't played around much with 111105, though, so I'll try to reproduce the bug in that version.
Reply
03-13-2012 10:23 AM
G422 Co-Pilot Beta
 
i tried again, but no luck
Reply
03-13-2012 08:51 PM
Donator
 
Quote:
Originally Posted by ken1029
 i tried again, but no luck
You tried what again?
If you can reproduce the bug again, we might have a chance to further look into this issue.
If you have tried, but could not reproduce the problem...I would say this issue can be closed.
/Kuddel

P.S.: Please note, that these questions are not intended to sound harsh
Reply
Reply

Issue Tools
Subscribe to this issue

All times are GMT. The time now is 10:22 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2007 - 2012, Orbiter-Forum.com. All rights reserved.