Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Orbiter Beta Topics related to Beta releases of Orbiter and Orbiter development.

Reply
 
Thread Tools
Old 01-23-2016, 04:02 PM   #16
TCR_500
Biblical Creationist
Default

Quote:
Originally Posted by Post much? View Post
 Grid resolution 129 with maximum quality:

{image}

If this is what it looks like with the LOLA-only data, imagine the Terrain Camera DTM!
That would kill my GPU for sure. I never thought I'd see the day when Orbiter would become resource hungry without mods.
TCR_500 is offline   Reply With Quote
Thanked by:
Old 01-23-2016, 06:11 PM   #17
Post much?
Orbinaut
Default

This was made with only the onboard HD4600 of my i5
I got roughly the same FPS martins did at the same settings.
Post much? is offline   Reply With Quote
Old 01-23-2016, 07:03 PM   #18
ADSWNJ
Scientist
 
ADSWNJ's Avatar
Default

What's the latest advice on how to install hi-res textures on top of this beta. What's the recommended set of links for hi-res Earth, Moon, and Mars?

Assume here: http://mirror.orbiter-radio.co.uk/or...turepacks.html right?

Last edited by ADSWNJ; 01-23-2016 at 07:31 PM.
ADSWNJ is offline   Reply With Quote
Old 01-23-2016, 09:47 PM   #19
turtle91
Orbinaut
Default

That's the textures I have used.
I installed all the low-res packs + one hires-tile for KSC.
Looks nice
turtle91 is offline   Reply With Quote
Old 01-23-2016, 10:53 PM   #20
GZR_Ranger
Orbinaut
Default XR-2 issues with r.45 Beta

Hi. I'm not an expert, and could use some expert help! I see from other posts that several of you have the XR-2 working in the beta, but I'm having trouble. I hope it's something simple that I'm screwing up!

Due to the blizzard the east coast of the USA is having, I took time today to download the new beta. My last install (r.43) was CTD'ing, so this time I installed everything one-at-a-time and started Orbiter after each was installed:
  1. Orbiter Beta r45 (hires textures copied form older version)
  2. EarthHi_10_08_diff.7z
  3. D3D9ClientBeta15-forRev45.zip
  4. IMFD55.zip
  5. OrbiterSound40_20121120_setup.exe
  6. UCGO30_2010_20140109.exe
  7. XR2Ravenstar-1.6a.zip
  8. XR2Ravenstar-1.7-beta.zip

After the XR-2 install, Orbiter now CTD's shortly after initiating any scenario (even if it's not an XR-2 scenario).

Thank you!

From XR2Ravenstar.log
Code:
01.23.2016 17:14:44.424 - [] Loading XR2Ravenstar: Version 1.7 BETA-1, Build Date: Jul 22 2013
01.23.2016 17:14:44.475 - [XR2-01] Using configuration file(s): Config\XR2RavenstarPrefs.cfg (no override found [Config\XR2-01.xrcfg])
01.23.2016 17:14:44.475 - [XR2-01] Parsing config file 'Config\XR2RavenstarPrefs.cfg'
01.23.2016 17:14:44.510 - [XR2-01] Successfully parsed configuration file 'Config\XR2RavenstarPrefs.cfg'
01.23.2016 17:14:47.904 - [XR2-01] Using UMmu Version: 3.00
01.23.2016 17:14:50.076 - [XR2-01] Using OrbiterSound Version: 4.00
01.23.2016 17:14:52.052 - [XR2-01] Autodetected video window width: 1360 pixels
From Orbiter.log
Code:
**** Orbiter.log
000000.000: Build Jan 20 2016 [v.160120]
000000.000: Timer precision: 3.94741e-007 sec
000000.000: Found 0 joystick(s)
000000.000: Module AtlantisConfig.dll .... [Build 150906, API 150906]
000000.000: Module AtmConfig.dll ......... [Build 150906, API 150906]
000000.000: Module DGConfigurator.dll .... [Build 150906, API 150906]
000000.000: Module D3D9Client.dll ........ [Build 160121, API 160120]
000000.000: Module InterMFD55.dll ........ [Build 100826, API 100704]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: oapiRegisterMFDMode
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
000000.000: Module OrbiterSound.dll ...... [Build 121120, API 100830]
000000.000: 
000000.000: **** Creating simulation session
000000.000: D3D9Client: [DirectX 9 Initialized]
000000.000: D3D9Client: Sytem has XNA math support
000000.000: D3D9Client: [3DDevice Initialized]
000000.000: D3D9Client: [Loading Stars]
000000.000: D3D9Client: [Loading Constellations]
000000.000: D3D9Client: [D3D9Client Initialized]
000000.000: Attempting to clear a texture 0x7319680 color=0x0
000000.000: Module Sun.dll ............... [Build 150906, API 150906]
VSOP87(E) Sun: Precision 1e-006, Terms 554/6634
000000.000: Module Mercury.dll ........... [Build 150906, API 150906]
VSOP87(B) Mercury: Precision 1e-005, Terms 167/7123
000000.000: Module Venus.dll ............. [Build 150906, API 150906]
000000.000: Module VenusAtm2006.dll ...... [Build 150906, API 150906]
VSOP87(B) Venus: Precision 1e-005, Terms 79/1710
000000.000: Module Earth.dll ............. [Build 150906, API 150906]
000000.000: Module EarthAtm2006.dll ...... [Build 150906, API 150906]
VSOP87(B) Earth: Precision 1e-008, Terms 2564/2564
000000.000: Module Moon.dll .............. [Build 150906, API 150906]
ELP82: Precision 1e-005, Terms 116/829
000000.000: Module Mars.dll .............. [Build 150906, API 150906]
000000.000: Module MarsAtm2006.dll ....... [Build 150906, API 150906]
VSOP87(B) Mars: Precision 1e-005, Terms 405/6400
000000.000: Module Phobos.dll ............ [Build ******, API 060425]
000000.000: Module Deimos.dll ............ [Build ******, API 060425]
000000.000: Module Galsat.dll ............ [Build 150906, API 150906]
000000.000: Module Jupiter.dll ........... [Build 150906, API 150906]
VSOP87(B) Jupiter: Precision 1e-006, Terms 1624/3625
000000.000: Module Io.dll ................ [Build 150906, API 150906]
000000.000: Module Europa.dll ............ [Build 150906, API 150906]
000000.000: Module Ganymede.dll .......... [Build 150906, API 150906]
000000.000: Module Callisto.dll .......... [Build 150906, API 150906]
000000.000: Module Satsat.dll ............ [Build 150906, API 150906]
000000.000: Module Saturn.dll ............ [Build 150906, API 150906]
VSOP87(B) Saturn: Precision 1e-006, Terms 2904/6365
000000.000: Module Mimas.dll ............. [Build 150906, API 150906]
SATSAT Mimas: Terms 113
000000.000: Module Enceladus.dll ......... [Build 150906, API 150906]
SATSAT Enceladus: Terms 33
000000.000: Module Tethys.dll ............ [Build 150906, API 150906]
SATSAT Tethys: Terms 101
000000.000: Module Dione.dll ............. [Build 150906, API 150906]
SATSAT Dione: Terms 59
000000.000: Module Rhea.dll .............. [Build 150906, API 150906]
SATSAT Rhea: Terms 68
000000.000: Module Titan.dll ............. [Build 150906, API 150906]
SATSAT Titan: Terms 100
000000.000: Module Iapetus.dll ........... [Build 150906, API 150906]
SATSAT Iapetus: Terms 605
000000.000: Module Uranus.dll ............ [Build 150906, API 150906]
VSOP87(B) Uranus: Precision 1e-006, Terms 1827/5269
000000.000: Module Miranda.dll ........... [Build ******, API 060425]
000000.000: Module Ariel.dll ............. [Build ******, API 060425]
000000.000: Module Umbriel.dll ........... [Build ******, API 060425]
000000.000: Module Titania.dll ........... [Build ******, API 060425]
000000.000: Module Oberon.dll ............ [Build ******, API 060425]
000000.000: Module Neptune.dll ........... [Build 150906, API 150906]
VSOP87(B) Neptune: Precision 1e-006, Terms 391/2024
000000.000: Finished initialising world
000000.000: Module XR2Ravenstar.dll ...... [Build 130722, API 130101]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: VESSEL::CreateVariableDragElement
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
000000.000: Module ShuttleA.dll .......... [Build 151205, API 151205]
000000.000: Module ShuttlePB.dll ......... [Build 150906, API 150906]
000000.000: Module DeltaGlider.dll ....... [Build 160120, API 160120]
000000.000: Module LuaInline.dll ......... [Build 150906, API 150906]
000000.000: Finished initialising status
000000.000: Finished initialising camera
000000.000: Finished setting up render state
000000.000: WARNING: No texture data found for Mars (TileFormat = 2)
000000.000: D3D9Client: [Scene Initialized]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: oapiBlt
000000.000: Colour key argument not supported by graphics client
000000.000: ---------------------------------------------------------------
000000.000: Finished initialising panels
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: VESSEL::GetHorizonAirspeedVector
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
GZR_Ranger is offline   Reply With Quote
Old 01-24-2016, 08:00 AM   #21
T1234
Orbinaut
Default

D3D9 R45 was crashing on loading and had similar orbiterlog to yours, so using R44 version. Do you have Lo earth,mars,moon and minor bodies installed?
T1234 is offline   Reply With Quote
Old 01-25-2016, 04:28 PM   #22
GZR_Ranger
Orbinaut
Default

Well, I did a clean install of Orbiter Beta, to include the textures. It works, EXCEPT when I go to the panel view on the XR-2. When going to the panel, it CTD's Is there some add-on that I need to have to get the panel to work? I've tried my config settings in XR2RavenstarPrefs.cfg... Any suggestions?

One thing I'm unsure of is this:

Code:
000000.000: >>> WARNING: Obsolete API function used: VESSEL::CreateVariableDragElement
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
GZR_Ranger is offline   Reply With Quote
Old 01-25-2016, 05:20 PM   #23
martins
Orbiter Founder
Default

Quote:
Originally Posted by GZR_Ranger View Post
 One thing I'm unsure of is this:

Code:
000000.000: >>> WARNING: Obsolete API function used: VESSEL::CreateVariableDragElement
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
No that shouldn't cause crashes. More of a problem might be this:
Quote:
000000.000: WARNING: No texture data found for Mars (TileFormat = 2)
Did you not install the Mars textures? It's possible that the code requires planet textures at least to the root of the quadtree to be present (resolution level 4). Although I don't know if this would trigger a problem when Mars is not in view (I should test this). And there definitely shouldn't be any correlation with XR-2.

Do you get crashes only with the combination D3D9+XR2? Do each if these work individually in the latest beta?
martins is offline   Reply With Quote
Thanked by:
Old 01-25-2016, 06:55 PM   #24
turtle91
Orbinaut
Default

As far as I rember, the inline graphics-client worked for me after installing only the eath-lowres-textures.
But the D3D9-client was crashing orbiter, until I have installed all the other available low-res-packs.
However, I have tried to use the modified XR2, too.
It worked, until I installed the KSC hires-texture-pack.
Now I am getting random CTD's on my Desktop.
I believe in my case, it's just some kind of out-of-memory-issue.
The same setup-works good on my laptop, which has more main-memory and video-memory compared to my old WinXP desktop, but I didn't test the XR2 on this box, yet.
turtle91 is offline   Reply With Quote
Old 01-25-2016, 08:05 PM   #25
Marg
Orbinaut
Default

Sorry I still have not updated to r45. .. but I noticed something odd.
I orbited the moon with Apollo vessels (LM+SM). When I was in external camera view and close to vessels, a heavy flickering of lunar craters happened (45 degrees off the down looking point and more towards the horizon). Orbiter visualized crater "inside part" as it was the closest wall that flickered. But when I moved camera further away from vessels (100 m or more) it did not happen anymore. What can that be?
Marg is offline   Reply With Quote
Old 01-25-2016, 08:18 PM   #26
turtle91
Orbinaut
Default

I found another issue with the new DG:

Whenver I load a scenario with the new DG docked to whatever vessel, Orbiter CTD's while loading the scenario, but no erros logged.
Happens with inline+external graphics-client.
Maybe related with the new "Oxygen-Pressure" feature in new DG ?

To solve this, I need to remove the docking-relevant entries in the SCN-file, and reload the scenario.
Then the scenario loads up without problems.
Right after loading-up , the DG docks again...as expected.
turtle91 is offline   Reply With Quote
Old 01-25-2016, 08:47 PM   #27
DaveS
Addon Developer
 
DaveS's Avatar


Default

Quote:
Originally Posted by turtle91 View Post
 I found another issue with the new DG:

Whenver I load a scenario with the new DG docked to whatever vessel, Orbiter CTD's while loading the scenario, but no erros logged.
Happens with inline+external graphics-client.
Maybe related with the new "Oxygen-Pressure" feature in new DG ?

To solve this, I need to remove the docking-relevant entries in the SCN-file, and reload the scenario.
Then the scenario loads up without problems.
Right after loading-up , the DG docks again...as expected.
This has nothing to the with the DG or any other vessel but everything to do with OrbiterSound. OS just isn't 100% compatible with Beta version(s).
DaveS is offline   Reply With Quote
Thanked by:
Old 01-25-2016, 08:56 PM   #28
turtle91
Orbinaut
Default

Yes...you are right. Disabled Orbiter-Sound module and loading of the SCN worked fine.
Sorry, for not cross-checking.
turtle91 is offline   Reply With Quote
Old 01-25-2016, 09:29 PM   #29
jarmonik
Beta Tester

Default

I made some tests with XR-2 Ravenstar and it is causing a CTD with D3D9 as well as with the inline engine. Debugger shows no leads, no D3D9 calls in a call stack or being executed.

Removed Mars and Moon textures from an installation to test texture dependency. No CTDs, rendered as black spheres.

---------- Post added at 23:29 ---------- Previous post was at 23:25 ----------

Quote:
Originally Posted by turtle91 View Post
 But the D3D9-client was crashing orbiter, until I have installed all the other available low-res-packs.
I wasn't able to reproduce, if you experience something like that once more then, please, report in D3D9 thread.
jarmonik is offline   Reply With Quote
Thanked by:
Old 01-25-2016, 10:08 PM   #30
turtle91
Orbinaut
Default

>I wasn't able to reproduce, if you experience something like that once more then, please, report in D3D9 thread.

Will do so. I have nothing reported, because I thought the low-res packs were a (not just visual)requirement.
turtle91 is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Beta


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 05:24 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2012, Orbiter-Forum.com. All rights reserved.