Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

General Questions & Help General & Advanced Orbiter flight questions, Orbiter installation questions, to all other help topics here.

Reply
 
Thread Tools
Old 12-05-2016, 08:51 PM   #1
LiamS2005
Orbinaut
Unhappy Orbiter 2016 Freezes Right After Loading

So I recently installed Orbiter 2016 and opened up the intro. The loading screen pops up and goes away after a couple of seconds, but after that, the game just froze. I haven't been able to find anything that is the same as this, so I am posting it here. Also, I have not installed any addons and have tried re-installing it, but that didn't do anything. I used the MSI install and installed it to D:\Orbiter2016. Here is my Orbiter.log file,

**** Orbiter.log
000000.000: Build Aug 28 2016 [v.160828]
000000.000: Timer precision: 3.95062e-007 sec
000000.000: Found 0 joystick(s)
000000.000: Devices enumerated: 6
000000.000: Devices accepted: 5
000000.000: [ ] RGB Emulation (SW)
000000.000: [ ] Direct3D HAL (HW)
000000.000: [x] Direct3D T&L HAL (HW)
000000.000: [ ] Direct3D HAL (Intel(R) HD Graphics 520) (HW)
000000.000: [x] Direct3D T&L HAL (Intel(R) HD Graphics 520) (HW)
000000.000: Module AtlantisConfig.dll .... [Build 160828, API 160828]
000000.000: Module AtmConfig.dll ......... [Build 160828, API 160828]
000000.000: Module DGConfigurator.dll .... [Build 160828, API 160828]
000000.000:
000000.000: **** Creating simulation session
000000.000: DirectDraw interface OK
000000.000: Direct3D interface OK
000000.000: Graphics: Viewport: Window 1360 x 739 x 32
000000.000: Graphics: Hardware T&L capability: Yes
000000.000: Graphics: Z-buffer depth: 32 bit
000000.000: Graphics: Active lights supported: 8
000000.000: Loading 15382 records from star database
000000.000: ---------------------------------------------------------------
000000.000: >>> ERROR: DDraw error DDERR_BLTFASTCANTCLIP
000000.000: >>> [OrbiterGraphics::clbkBlt | .\OGraphics.cpp | 1633]
000000.000: ---------------------------------------------------------------
000000.000: Module Sun.dll ............... [Build 160828, API 160828]
VSOP87(E) Sun: Precision 1e-006, Terms 554/6634
000000.000: Module Mercury.dll ........... [Build 160828, API 160828]
VSOP87(B) Mercury: Precision 1e-005, Terms 167/7123
000000.000: Module Venus.dll ............. [Build 160828, API 160828]
000000.000: Module VenusAtm2006.dll ...... [Build 160828, API 160828]
VSOP87(B) Venus: Precision 1e-005, Terms 79/1710
000000.000: Module Earth.dll ............. [Build 160828, API 160828]
000000.000: Module EarthAtmJ71G.dll ...... [Build 160828, API 160828]
VSOP87(B) Earth: Precision 1e-008, Terms 2564/2564
000000.000: Module Moon.dll .............. [Build 160828, API 160828]
ELP82: Precision 1e-005, Terms 116/829
000000.000: Module Mars.dll .............. [Build 160828, API 160828]
000000.000: Module MarsAtm2006.dll ....... [Build 160828, API 160828]
VSOP87(B) Mars: Precision 1e-005, Terms 405/6400
000000.000: Module Phobos.dll ............ [Build ******, API 060425]
000000.000: Module Deimos.dll ............ [Build ******, API 060425]
000000.000: Module Galsat.dll ............ [Build 160828, API 160828]
000000.000: Module Jupiter.dll ........... [Build 160828, API 160828]
VSOP87(B) Jupiter: Precision 1e-006, Terms 1624/3625
000000.000: Module Io.dll ................ [Build 160828, API 160828]
000000.000: Module Europa.dll ............ [Build 160828, API 160828]
000000.000: Module Ganymede.dll .......... [Build 160828, API 160828]
000000.000: Module Callisto.dll .......... [Build 160828, API 160828]
000000.000: Module Satsat.dll ............ [Build 160828, API 160828]
000000.000: Module Saturn.dll ............ [Build 160828, API 160828]
VSOP87(B) Saturn: Precision 1e-006, Terms 2904/6365
000000.000: Module Mimas.dll ............. [Build 160828, API 160828]
SATSAT Mimas: Terms 113
000000.000: Module Enceladus.dll ......... [Build 160828, API 160828]
SATSAT Enceladus: Terms 33
000000.000: Module Tethys.dll ............ [Build 160828, API 160828]
SATSAT Tethys: Terms 101
000000.000: Module Dione.dll ............. [Build 160828, API 160828]
SATSAT Dione: Terms 59
000000.000: Module Rhea.dll .............. [Build 160828, API 160828]
SATSAT Rhea: Terms 68
000000.000: Module Titan.dll ............. [Build 160828, API 160828]
SATSAT Titan: Terms 100
000000.000: Module Iapetus.dll ........... [Build 160828, API 160828]
SATSAT Iapetus: Terms 605
000000.000: Module Uranus.dll ............ [Build 160828, API 160828]
VSOP87(B) Uranus: Precision 1e-006, Terms 1827/5269
000000.000: Module Miranda.dll ........... [Build ******, API 060425]
000000.000: Module Ariel.dll ............. [Build ******, API 060425]
000000.000: Module Umbriel.dll ........... [Build ******, API 060425]
000000.000: Module Titania.dll ........... [Build ******, API 060425]
000000.000: Module Oberon.dll ............ [Build ******, API 060425]
000000.000: Module Neptune.dll ........... [Build 160828, API 160828]
VSOP87(B) Neptune: Precision 1e-006, Terms 391/2024
000000.000: Finished initialising world
000000.000: Module Atlantis_SRB.dll ...... [Build 160828, API 160828]
000000.000: Module Atlantis_Tank.dll ..... [Build 160828, API 160828]
000000.000: Module Atlantis.dll .......... [Build 160828, API 160828]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: VESSEL::CreateVariableDragElement
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
000000.000: Module ShuttleA.dll .......... [Build 160828, API 160828]
000000.000: Finished initialising status
000000.000: Finished initialising camera
000000.000: Finished setting up render state
000000.000: Finished initialising panels

help!
LiamS2005 is offline   Reply With Quote
Old 12-16-2016, 11:58 PM   #2
bisbeejim
Orbinaut
 
bisbeejim's Avatar
Default Unable to replicate the problem

Hi Liam,
I examined your post. I've been unable to duplicate the problem you've encounted. Also I've not seen anything on your log that indicated the issue. Have you uncovered a resolution or have you gone back to Orbiter 2010?
bisbeejim is offline   Reply With Quote
Old 12-17-2016, 12:52 AM   #3
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

It looks like you're using Intel integrated graphics:

Code:
[x] Direct3D T&L HAL (Intel(R) HD Graphics 520) (HW)
It is likely your problem is caused by a bug or limitation in your integrated graphics video driver related to its DirectX7 support. I suggest either trying the D3D9 client or, if you can, switching to a discrete video card rather than using Intel HD graphics. We have seen lots of issues with Intel HD graphics and 3D games like Orbiter before.
dbeachy1 is offline   Reply With Quote
Old 12-20-2016, 09:56 PM   #4
LiamS2005
Orbinaut
Default

I will try that.
LiamS2005 is offline   Reply With Quote
Old 12-20-2016, 10:08 PM   #5
LiamS2005
Orbinaut
Default

I have installed the D3D9 client, but it didn't fix anything. When using RGB Emulation, the game runs, but the Space Shuttle texture is missing and particles aren't rendered properly. I will try to send a screenshot.
LiamS2005 is offline   Reply With Quote
Old 12-20-2016, 10:12 PM   #6
LiamS2005
Orbinaut
Default

[IMG]file:///D:/Videos%202/Bandicam%202/bandicam%202016-12-21%2009-10-14-618.jpg[/IMG]
LiamS2005 is offline   Reply With Quote
Old 12-22-2016, 06:24 PM   #7
garyw
O-F Administrator
 
garyw's Avatar


Default

You can't post a video by posting a link to your hard disks D: drive.....
garyw is offline   Reply With Quote
Old 12-22-2016, 06:44 PM   #8
jgrillo2002
Space Explorer
 
jgrillo2002's Avatar
Default

Oooh. Yea I dont think this version can cut a integrate graphic GPU. IMHO they suck when it comes for graphics acceleration. If its a laptop I suggest a laptop that has a dedicated GPU like a GTX960M
jgrillo2002 is offline   Reply With Quote
Old 12-23-2016, 05:02 AM   #9
dbeachy1
O-F Administrator
 
dbeachy1's Avatar


Default

Quote:
Originally Posted by LiamS2005 View Post
 When using RGB Emulation, the game runs, but the Space Shuttle texture is missing and particles aren't rendered properly. I will try to send a screenshot.
Note that RGB Emulation won't work -- you need to choose a video mode that supports T&L (Transform & Lighting).

Also, I don't remember the D3D9 client even showing the option for RGB Emulation -- are you sure you are running the D3D9 client? You have to launch orbiter_ng.exe, not orbiter.exe, and then load the 'D3D9Client' module in "Modules". Then choose a '3D Device' in the Video tab, then choose a scenario and click "Launch Orbiter"
dbeachy1 is offline   Reply With Quote
Thanked by:
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > General Questions & Help


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 12:52 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2012, Orbiter-Forum.com. All rights reserved.