Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Notices

Orbiter Visualization Project Orbiter external graphics development.

Reply
 
Thread Tools
Old 06-10-2010, 09:31 PM   #61
Grawp
Orbinaut
Default

It's quite funny that the cube test work for me only under wine. In WinXP the main texture of the cube is not visible (transparent). Yeah.. I have the most recent directcrap a nvidia drivers (7600GT).
I'll make some screenshots from win. But here is one from wine:

It's only orbiter base, DGIV and OGLA. There is some problem with DG textures... they're white for unknown reason both in win and wine. And there is slight fps drop in cockpit in wine.
Attached Thumbnails
snapshot1.png  
Grawp is offline   Reply With Quote
Old 06-10-2010, 11:16 PM   #62
Columbia42
Orbinaut
 
Columbia42's Avatar
Default

Ogla seems to be working alright-ish for me except for the MFDs; they just display gibberish. In VC mode some MFDs are fine but not all of them. Turning on GDI Emulation doesn't fix the problem.
Columbia42 is offline   Reply With Quote
Old 06-11-2010, 04:15 PM   #63
cinder1992
Random failhurricane.
 
cinder1992's Avatar

Default

Just as a word of warning, OGLA will NOT work with an ATI Radeon 9600. it seems that all the 10xxxx versions are incompatible, witch isn't a surprise, as the 9600 is an OLD card.

(yes Artlav, I even turned off GDI emulation, It crashes the moment the start-up screen pops up.)
cinder1992 is offline   Reply With Quote
Old 06-11-2010, 06:44 PM   #64
Artlav
Aperiodic traveller
 
Artlav's Avatar

Default

Quote:
Originally Posted by mc_ View Post
 сейчас словил вылет на вроде как пропатченой версии XR2.
ogla.log набит сообщениями вида
Code:
09.06.2010-18:45:52:[OGLCTEX   ]:Error: Error in txget
При этом посттоянно вылезал рандомный глюк с приборными панелями - они выглядели как черные прямоугольники, поверх которых нарисованы МФД и кнопки. При многократном переключении между панелями (главная/низ/оверхед) глюк пропадал, но кончилось это дело вылетом.
Ну да, это что-то от GDI вроде, не всегда удаётся взять поверхность.
Про txget - возможно ли точно поймать момент, когда они появляются?
Должно накопиться в сумме 20 ошибок прежде чем будет произведён вылет.

Quote:
Originally Posted by mc_ View Post
 
Code:
09.06.2010-18:35:13:[getheihmap]:Notice: File "heightmaps\Earth-lv12-870-188-21-15.hei" not found or not loadable.
Это нормально, какой-то рудимент от орулекса. Тех древних текстур нет, и об их отсутствии сообщается. Все почему-то воспринимают это как какую-то ошибку, хотя я несколько раз менял формулировку.

Quote:
Originally Posted by Izack View Post
 When Earthlight is on, vessels glow ambiently in daylight, and are pitch black at night. When it is off, all objects that you didn't texture (IE default Orbiter objects and the parts of the deltaglider without flames) are pitch-black no matter what.
Ok, could you run this:
http://orbides.1gb.ru/orbf/glgr_test.zip
And post the glgr.txt along with the screenshot it generates?

Quote:
Originally Posted by Grawp View Post
 There is some problem with DG textures... they're white for unknown reason both in win and wine. And there is slight fps drop in cockpit in wine.
As the manual says, DGIV does not support OGLA (or vice-versa).

Quote:
Originally Posted by cinder1992 View Post
 Just as a word of warning, OGLA will NOT work with an ATI Radeon 9600. it seems that all the 10xxxx versions are incompatible, witch isn't a surprise, as the 9600 is an OLD card.
(yes Artlav, I even turned off GDI emulation, It crashes the moment the start-up screen pops up.)
If you want me to fix that, please provide ogla.log from the crash, and run this thing:
http://orbides.1gb.ru/orbf/glgr_test.zip
Posting the glgr.txt please.
OGLA works under a bare-bones OpenGL software renderer i made for my OS, so some old GPU must be at least basically supported.
Artlav is offline   Reply With Quote
Old 06-11-2010, 07:28 PM   #65
computerex
Addon Developer
Default

No issues, I thought you might find the test output useful.
Attached Files
File Type: txt glgr.txt (3.8 KB, 18 views)
computerex is offline   Reply With Quote
Old 06-14-2010, 01:14 PM   #66
Samuel Edwards
Decidedly Cyclical
 
Samuel Edwards's Avatar
Default

Quote:
Originally Posted by cinder1992 View Post
 Just as a word of warning, OGLA will NOT work with an ATI Radeon 9600. it seems that all the 10xxxx versions are incompatible, witch isn't a surprise, as the 9600 is an OLD card.

(yes Artlav, I even turned off GDI emulation, It crashes the moment the start-up screen pops up.)
that's just great, I think that is the card I use. Why is it always that way. Why couldn't it be a different card.
Samuel Edwards is online now   Reply With Quote
Old 06-14-2010, 01:18 PM   #67
Xyon
Puts the Fun in Dysfunctional
 
Xyon's Avatar


Default

I sincerely doubt it's that card in particular. The 9600 is an exceptionally old card - I think I bought one as scrap stock back in 2003. Barring an upgrade, there isn't much you're going to be able to do about it, and most cards that old will have serious trouble with the OGLA client.
Xyon is offline   Reply With Quote
Old 06-14-2010, 01:21 PM   #68
Samuel Edwards
Decidedly Cyclical
 
Samuel Edwards's Avatar
Default

Attachment 4954

There's my test result.

Last edited by Samuel Edwards; 06-21-2011 at 02:48 PM.
Samuel Edwards is online now   Reply With Quote
Old 06-14-2010, 01:24 PM   #69
Samuel Edwards
Decidedly Cyclical
 
Samuel Edwards's Avatar
Default

Just checked, it appears that I don't have that card.
Samuel Edwards is online now   Reply With Quote
Old 06-14-2010, 01:34 PM   #70
Artlav
Aperiodic traveller
 
Artlav's Avatar

Default

Quote:
Originally Posted by Samuel Edwards View Post
 Attachment 4954

There's my test result.
That's a rather good card, and most features needed for full advanced graphics seems supported. What exactly is the wrong and bad things you see?
Any screenshots?
What is there in ogla.log?
Artlav is offline   Reply With Quote
Old 06-14-2010, 01:36 PM   #71
Samuel Edwards
Decidedly Cyclical
 
Samuel Edwards's Avatar
Default

Quote:
Originally Posted by Artlav View Post
 That's a rather good card, and most features needed for full advanced graphics seems supported. What exactly is the wrong and bad things you see?
Any screenshots?
What is there in ogla.log?

Hold on, while I go and take some shots.
Samuel Edwards is online now   Reply With Quote
Old 06-14-2010, 01:51 PM   #72
Samuel Edwards
Decidedly Cyclical
 
Samuel Edwards's Avatar
Default

Attachment 4956



Those are some screenshots I took at minimal settings.

Last edited by Samuel Edwards; 01-24-2017 at 07:25 PM.
Samuel Edwards is online now   Reply With Quote
Old 06-14-2010, 03:04 PM   #73
Artlav
Aperiodic traveller
 
Artlav's Avatar

Default

Quote:
Originally Posted by Samuel Edwards View Post
 Those are some screenshots I took at minimal settings.
ogla.log?
Check installation.
Make sure Stereo mode is off in settings (F7-A).
Make sure second camera is off.
Make sure you set the screen resolution properly (like in regular Orbiter).

I only see one screenshot.
Artlav is offline   Reply With Quote
Old 06-14-2010, 04:05 PM   #74
mc_
Orbinaut
 
mc_'s Avatar
Bug Фикс поглючен

Quote:
Originally Posted by Artlav View Post
 Ну да, это что-то от GDI вроде, не всегда удаётся взять поверхность.
Про txget - возможно ли точно поймать момент, когда они появляются?
Должно накопиться в сумме 20 ошибок прежде чем будет произведён вылет.
При переключении 2D-панелей на новом XR2 (вроде как пропатченом под Орбитер 2010), причем не всегда. Если глюк появился, можно несколько раз переключить панели туда-сюда, и он пропадет.

Кстати, еще глюки:
  • нет теней. Вообще. Ни на каких настройках.
  • Демка с кубиком глючит (пятна света на боковых гранях, тут уже выкладвали скрин)
  • текстуры при взгляде с орбиты просто ужасны, при том, что скачал и поставил L14
  • У UMMU при виде от первого лица все время опущен светофильтр (при том, что он ясно виден поднятым).

Last edited by mc_; 06-14-2010 at 04:09 PM.
mc_ is offline   Reply With Quote
Old 06-14-2010, 06:58 PM   #75
fort
Orbinaut
Default

It works, more or less well, on my computer, but that works. By the fact, I discover OGLA 2010, and I have to proceed to some essays and to complete my different readings concerning OGLA (that I had nevertheless tested in the past a year or more ago). In addition, my card, an old and pseudo ATI (pseudo: a sold one of license or a concession if I well understood at the moment I tried some years ago to know what I had just obtained), my card continues to astonish me as for its performances, comparatively to its capacities, and for the price that I had paid it, a bargain (can be about twenty Euros). But I believe that I had found a good pilots for it.

--GPU info:--
Name=RADEON 7500 Series (Omega 3.8.252)
Description=RADEON 7500 Series (Omega 3.8.252)
AdapterCompatibility=ATI Technologies Inc. (Omega 3.8.252)
AdapterRAM=64 Mb
VideoModeDescription=1024 x 768 x 4294967296 couleurs
VideoProcessor=RADEON 7500 Series AGP (0x5157)
DriverVersion=6.14.10.6614

--OpenGL info:--
GPU supports OpenGL 1.2
GPU does not support OpenGL 1.4 (No MFDs and panels)
GPU supports OpenGL 2.0
glgruva=1, usevbo=1, vboav=1, glgr_stensh_aupd=0, gl_comp_sup=1, gl_shm4=0

glGetCompressedTexImageARB=$04EB2A70
glGetCompressedTexImage=$04EB2A70

Extensions:
GL_ARB_multitexture GL_EXT_texture_env_add GL_EXT_compiled_vertex_array GL_S3_s3tc GL_ARB_occlusion_query GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_window_pos GL_ATI_envmap_bumpmap GL_ATI_map_object_buffer GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_vertex_array_object GL_ATI_vertex_streams GL_ATIX_texture_env_combine3 GL_ATIX_texture_env_route GL_EXT_abgr GL_EXT_bgra GL_EXT_clip_volume_hint GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_texgen_reflection GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_vertex_array GL_HP_occlusion_test GL_NV_blend_square GL_NV_occlusion_query GL_NV_texgen_reflection GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_WIN_swap_hint WGL_EXT_extensions_string WGL_EXT_swap_control
Vessel program:

I had some boredoms with that:

"Make turn sour you set the screen resolution properly (like in regular Orbiter)."...

...But it is correct now, for the launch, at less (...for sure, without MFD. ..it risks to be a little short...).

Thank you Artlav

I will continue to read what is said here.
fort is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 08:28 PM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 - 2012, Orbiter-Forum.com. All rights reserved.