Orbiter-Forum  

Go Back   Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project
Register Blogs Orbinauts List Social Groups FAQ Projects Mark Forums Read

Notices

Orbiter Visualization Project Orbiter external graphics development.

Reply
 
Thread Tools
  #1  
Old
Artlav's Avatar
Artlav Artlav is offline
Aperiodic traveller

Default OGLAClient 100608 (Second Tuesday edition)
by Artlav 06-08-2010, 03:45 AM


OGLAClient 100608:
sourceforge.net/projects/orbitervis/files/OVP%20binaries/oglaclient-100608.zip/download
Last one is 100608-bis: https://sourceforge.net/projects/orb...s.zip/download
Info in post 34.
Earth scatter tables (for raytraced sky):
https://sourceforge.net/projects/orb...r.zip/download

This is Orbiter 2010P0 tie-in release of OGLAClient, the OpenGL graphics client for Orbiter.
The thing is still somewhat far from being really playable, but i tried to get rid of as many known bugs as possible and to fix all known features.
Detailed documentation on features, installation and OglaSDK is included into the zip file.
OglaSDK and some examples are also included.

EDIT: If you run scenarios with OGLA vessels in normal Orbiter you will get an OGLA wrong loading notice (or it will appear to hang up if in full-screen mode). This could be disabled from OGLA settings ("Check NG"), or in cfg file (Check_for_NG=0)
EDIT2: The file was re-uploaded with fix for above and full-screen mode strip bug. Please re-download if affected.

Changes since last beta:
* MipMaps creation control in config button
* Fixed specular in advanced graphics mode (XR2)
* Fixed no textures in AG mode bug
* Fixed raytraced sky on other planets
* Fixed and added support for annotations
* Fixed shadow offset bug (Atlantis)
* Added check for Orbiter.exe, disableable by cfg
* Fixed raytraced sky in unusual projections
* Fixed and updated config generation
* Fixed sky brightness in normal modes
* Cleaned up and updated F7 menu
* Added toggles for Stereo mode and Earthlight
* Fixed mesh visibility modes (many vessels, XR2, ummucone, etc)
* Fixed font-related crash
* Fixed ring illumination weirdness
* Fixed grainy rings
* Fixed GDI emulation for legacy MFDs
* Fixed invisible stars at night
* Added gradual orbital sunrise
* Fixed various blinking and broken annotations and menus

Known bugs and planned features (as of 100608-bis):
-Lightweight Lv9+ planet rendering (non-Orulex)
-Make Z-layer of Orulex a layer, not whole thing once again
-Make earthlight angle-dependent (dawn, sunset)
-Add particle streams (exhausts, reentry)
-Add planetarium mode
-Fix shadows in high mode+animations
-Recalibrate panel and fonts edge alignment (lines under text, crappy panels)
-Support for deallocation shutdown mode
-Fix visibility sequence for terrain (shadows ON)
-Fading exhaust to DaveS specs
-Shadows problem on Nvidia (?)
-F* key menus problems (?)
-Terrain tiling blinking issues (?)
-Proper tangent storage and handling (?)
-Animate tangent (?)
-NET: Camera panning, camera rolling
-NET: Complete network mode
-NET client: default size for the window
-SDK: Render to surface
-SDK: Add custom GLSL option to OglaSDK?

A few screenshots:





Last edited by Artlav; 06-08-2010 at 07:51 PM.
Reply With Quote
Views 58087 Comments 183
Total Comments 183

Comments

Old 06-08-2010, 03:48 AM   #2
supersonic
Add-on Developer
 
supersonic's Avatar

Default

Wow.
supersonic is offline   Reply With Quote
Old 06-08-2010, 04:04 AM   #3
Coolhand
Addon Developer
 
Coolhand's Avatar
Default

very cool work! i found a problem when flying around the pill object, the background stars tend to disappear and re appear i think based on the ships angle or something. I first noticed it when i loaded the scenario, and swung the ship around to look at earth, which was still unlit at that time. i'm using a 9800gt and xp.
Coolhand is offline   Reply With Quote
Old 06-08-2010, 04:10 AM   #4
Artlav
Aperiodic traveller
 
Artlav's Avatar

Default

Quote:
Originally Posted by Coolhand View Post
  the background stars tend to disappear and re appear i think based on the ships angle or something.
As in blink one by one, or something bad?
They might blink as an effect of smoothing, making them not as crisp-cut as in default rendering.
Artlav is offline   Reply With Quote
Old 06-08-2010, 04:12 AM   #5
supersonic
Add-on Developer
 
supersonic's Avatar

Default

My goal now is to get it to work.....
supersonic is offline   Reply With Quote
Thanked by:
Old 06-08-2010, 04:17 AM   #6
Artlav
Aperiodic traveller
 
Artlav's Avatar

Default

Important note:
If you run scenarios with OGLA vessels (Delatglider!) in normal Orbiter you will get an OGLA wrong loading notice (or it will appear to hang up if in full-screen mode). This could be disabled from OGLA settings ("Check NG"), or in cfg file (Check_for_NG=0)
Artlav is offline   Reply With Quote
Old 06-08-2010, 04:24 AM   #7
Izack
Non sequitur
 
Izack's Avatar

Default

I consistently get this:
[attachment]

Also, it only works in window mode, and even then only every other time I try to load it. Fullscreen mode on any resolution will give me a 10-pixel wide strip of Orbiter along the left side of my screen, and leave my desktop active.
Log says nothing unusual. I did the usual checking of the manual and rearranging of the options, to no effect. Obviously done on a clean install, following instructions to the letter.
Um, WTF?
Attached Thumbnails
ogla what.jpg  
Izack is offline   Reply With Quote
Old 06-08-2010, 04:25 AM   #8
Coolhand
Addon Developer
 
Coolhand's Avatar
Default

Quote:
Originally Posted by Artlav View Post
 As in blink one by one, or something bad?
They might blink as an effect of smoothing, making them not as crisp-cut as in default rendering.
i mean as in disappear completely. all of them. the planets remain as dots, the stars dissappear. Obviously its a recent install, but i have ummu, xr2 and orbiter sound installed so i guess that might be affecting it? i have orbiter sound module loaded too.

btw, earthlight is a cool feature, camera light doesn't seem to work and you should probably disable shadow casting on all but the sun.

i increased the shadow map size to 2048 and it looks pretty good and seems to run fast, definately the best shadows for performance at least for admiring a spaceship. it almost works inside the xr2's cockpit even where any other mode just falls apart completely.
Coolhand is offline   Reply With Quote
Old 06-08-2010, 04:39 AM   #9
Artlav
Aperiodic traveller
 
Artlav's Avatar

Default

Quote:
Originally Posted by Izack View Post
 I consistently get this:
What exactly is wrong in this image?

Quote:
Originally Posted by Izack View Post
 Also, it only works in window mode, and even then only every other time I try to load it. Fullscreen mode on any resolution will give me a 10-pixel wide strip of Orbiter along the left side of my screen, and leave my desktop active.
Weird, bug confirmed.
Full-screen mode was always more of a bug than a feature and it seems i totally forgot to test it out.

I've re-uploaded the file with a fix, try downloading again.

Quote:
Originally Posted by Coolhand View Post
 i mean as in disappear completely. all of them. the planets remain as dots, the stars dissappear.
Now that's something new. Any consistent way of reproducing it in controlled conditions?
Artlav is offline   Reply With Quote
Old 06-08-2010, 04:44 AM   #10
Coolhand
Addon Developer
 
Coolhand's Avatar
Default

fiddling with shadow settings again, seems the shadow maps play up if set too high, anything over 2048. set to 4096 they would look lovely and don't seem to kill the frames like high shadows.

*edit, no infact the shadow bug, which seems to be a projection angle issue appears with any shadow size, its just less vislble with 512 shadows... i think this issue has been around for some time so i'm sure its way down the list

however i thnk if you're looking to develop any particular shadow method, the maps seem to have the most potential so far for a clean, accurate realistic shadow... shadow maps also lose that hard edge that other methods can give so are liked by 3d artists as they look more natural, and are light on the cpu as opposed to raytracing for example. *

and i've captured the same bug as with the dg also in this shot. stars appearance seems dependant on camera angle.. seems that i can reproduce the effect in any orbital scenario.
Attached Thumbnails
oglatuesdayed_xr2shadows_nostars.jpg  

Last edited by Coolhand; 06-08-2010 at 04:58 AM.
Coolhand is offline   Reply With Quote
Old 06-08-2010, 04:53 AM   #11
Zachstar
Donator
 
Zachstar's Avatar

Default

Quite a few errors on my clean install. The worst being lockups that almost require computer restarts. They seem to happen worst on the two showoff scenarios.
Zachstar is offline   Reply With Quote
Old 06-08-2010, 05:30 AM   #12
Izack
Non sequitur
 
Izack's Avatar

Default

Quote:
Originally Posted by Artlav View Post
 What exactly is wrong in this image?
The textures on the Deltaglider are completely black, except for the flames you added.
Also, I'm set on 0 ambient lighting, and it has no effect on in-sim lighting.

Your fix worked; fullscreen works normally now, although it still only works every other attempt, inexplicably locking up on the other tries.

All objects besides the ones you made appear as completely black for me.
Attached Thumbnails
ogla what 2.jpg  
Izack is offline   Reply With Quote
Old 06-08-2010, 05:48 AM   #13
Xyon
82% caffeine
 
Xyon's Avatar


Default

To get the deltaglider working properly required recompiling it with the cpp file provided in the OGLA client's package, which wasn't an issue for me, but could be for some I suppose.

Recompiling it will enable you to see the DG working with multilight too, though I never did work out why the forward firing retros are causing the rear and wingtips to light up...
Xyon is offline   Reply With Quote
Old 06-08-2010, 05:58 AM   #14
Izack
Non sequitur
 
Izack's Avatar

Default

Quote:
Originally Posted by Xyon View Post
 To get the deltaglider working properly required recompiling it with the cpp file provided in the OGLA client's package, which wasn't an issue for me, but could be for some I suppose.

Recompiling it will enable you to see the DG working with multilight too, though I never did work out why the forward firing retros are causing the rear and wingtips to light up...
Well, I understood very little of that, so maybe this just isn't for me.

I did replace the old deltaglider files with the ones provided with the beta, which is I assume why the flames on the wings showed up, but I can't see how it's normal for every object to appear black and featureless if it weren't provided with the client.
Izack is offline   Reply With Quote
Old 06-08-2010, 06:33 AM   #15
Artlav
Aperiodic traveller
 
Artlav's Avatar

Default

Quote:
Originally Posted by Xyon View Post
 To get the deltaglider working properly required recompiling it with the cpp file provided in the OGLA client's package, which wasn't an issue for me, but could be for some I suppose.
Should not be, there is a precompiled DLL provided in the package.
Or, do you mean to say it does not work?

Quote:
Originally Posted by Izack View Post
 The textures on the Deltaglider are completely black, except for the flames you added.
Strange, Mobility Radeon HD 4330 is quite a recent card, should not give problems, in theory.
What if you disable multilight (F7-2)?
What if you disable advanced graphics (F7-U)?
Is there anything in ogla.log?
Does it stay black with out-of-the-box settings?
What do you mean by 0 ambient?

Quote:
Originally Posted by Izack View Post
 Your fix worked; fullscreen works normally now, although it still only works every other attempt, inexplicably locking up on the other tries.
At what point does it lock up?
If it's on exit and you have Vista then it's likely Orbiter bug.

Quote:
Originally Posted by Zachstar View Post
 Quite a few errors on my clean install. The worst being lockups that almost require computer restarts. They seem to happen worst on the two showoff scenarios.
Any definite way of reproducing this?
You have nivdia GPU, right?
Artlav is offline   Reply With Quote
Reply

  Orbiter-Forum > Orbiter Space Flight Simulator > Orbiter Visualization Project


Thread Tools

Posting Rules
BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


All times are GMT. The time now is 06:56 AM.

Quick Links Need Help?


About Us | Rules & Guidelines | TOS Policy | Privacy Policy

Orbiter-Forum is hosted at Orbithangar.com
Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2007 - 2012, Orbiter-Forum.com. All rights reserved.