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INTERPLANETARY MFD TUTO 
REVISED EXAMPLES FOR ORBITER 2016 & IMFD 5.7 

 
 

 
Interplanetary MFD is an Orbiter add-on created by Jarmo Nikkanen. 
It facilitates the travel throughout the solar system by calculating 

and displaying the vessel's predicted trajectories 
 

Credits: Dr. Martin Schweiger creator of the amazing Orbiter virtual world 
of planets, moon, spacecrafts and space stations 
Jarmo Nikkanen author of the Interplanetary MFD 

Mark Lieberbaum IMFD Full Manual 
Papyref  Pappy's Hangar - IMFD

 
REQUIRED 
IMFD 5.7 
http://users.kymp.net/p501474a/Orbiter/Orbiter.html 
 
REFERENCES 
IMFD Full Manual by Mark Lieberbaum 
https://www.orbiterwiki.org/wiki/IMFD_Manual 
Pappy's Hangar - IMFD 
http://francophone.dansteph.com/?page=search 
IMFDTuto 
https://www.orbithangar.com/search_quick.php?text=imfdtuto&submit
.x=0&submit.y=0 

 
 
 

NOTE: In order to save fuel, try to have your vessel parking and target orbits as aligned as possible 
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1 – EARTH TO MOON 
 

 
 

Step 1 . Target Intercept 
1. Left MFD →Open Course  →Target Intercept →TGT →enter Moon  →Realtime → Offplane →PRJ → 

Self →Z+ several times 
2. Right MFD →MNU → Opmode →enter  0  
3. Right MFD  →Map → TGT → enter Moon →Dsp → PG → Soi → Int → Plan → PG → Cnt → Sel →PRJ 

→ Self 
4. Open external MFD →REF enter the Moon →FRM →Equ  → PRJ→Shp  →DST 
5. Modify Tin in Target intercept to get rhe min dv ( = BT) 
6. Modify TEj  to get the blue line as close as possible to the periapsis blue dot  Warp 100X 
7. →PG→BV→AB autoburn 
8. →Warp 1000X until the vessel (white point in Map) reaches the Moon Soi and appears the 

message “Invalid Source of Reference” Warp 0.1X 
 
Step 2  Planer Approach 
9. Select Target Intercept →Menu (top right) →select Planet Approach → enter Eqi and PeA 
10. Close External MFD and,Open as Orbit in Right MFD 
11. Planet Approach →PG→BV→AB autoburn......wait end of burn 
 
Step 3  Orbit Insert 
12. In Planet Approach →Next →select Otbit Insert → REF=Moon → select Apoapsis →Next → aelect Alt 

enter desired altitude (Km) →PG→BV→AB autoburn  (you may warp 1000X until end of burn) 
 

 
The message “Invalid Source or Reference” will appear when overlaping the Moon Soi and Vessel 
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2 - MOON TO EARTH 
 

 
 
Step 1 Orbit Eject 
1. Left MFD  →Interplanetary  →Menu  →Orbit Eject → select Lower Orbit →PRJ → Self 
2. Right MFD →MNU → Opmode →enter  0  
3. Right MFD →Map → TGT enter Earth→Dsp →PG →Soi →Int →Plan →PG →Cnt →Sel →PRJ → Self 
4. Open external MFD →REF enter Earth→FRM →Equ  → PRJ→Shp  →DST 
5. Orbit Eject →Modify Tej to get the blue line over the green doted line 
6. Modify  oV to set PeA in Map as close as possible to desired Pea (Note; try to set warp 10X and change 

oV …..pay attention because it takes time to change PeA in Map) 
7. →PG →BV →AB autoburn 
8. Warp 1000X until the vessel reaches the Moon Soi and appears ·the message ““Have a nice voyage” 
 
Step 2  Planer Approach 
9. Left MFD  →Select Course → Planet Approach → enter Eqi and PeA 
10. Close External MFD and,Open as Orbit in right MFD  
11. Planet Approach →PG→BV→AB autoburn......wait end of burn 
 
Step 3  Orbit Insert 
12. Planet Approach →Next →select Otbit Insert → REF=Planet → select Apoapsis →Next → aelect Alt 

enter desired altitude (Km) →PG→BV→AB autoburn  (you may warp 1000X until end of burn) 
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3. EARTH TO MARS   
 

 
 

Step 1 . Orbit Eject 
1. Left MFD →Interplanetary→Menu  →Course →Target Intercept →TGT → enter Mars →PRJ →Self 
2. Right MFD →MNU → Opmode →enter  0→Orbit Eject → Select Course →PRJ →Self 
3. Open external MFD →REF enter the Earth→FRM →Equ  → PRJ→Shp  →DST 
4. Target Intercept → Modify Tin and TEj to minimize dV (BT)  in Orbit Eject 
5. Orbit Eject  → Modify Tej to get the blue line over the green doted line (min EjA / dV) 
6. →PG → BV → AB   
7. Warp 1000X until appears ·the message ““Have a nice voyage” 
 
Step 2 . Mid Course Correction 
8. Target Intercept  →PG →Src enter X to get the vessel as source 
9. Right MFD  →MNU → Map →TGT enter Mars→Dsp → PG → Soi → Int → Plan → PG → Cnt → Sel 
10. Read PeT and warp 1000X Wait until Pet about=1/2 of initial PeT and warp 1X 
11. →PG→BV→AB autoburn  
12. Warp 100000X and wait until the Target Intercept  shows the message “Invalid Source or Reference” 
13. Note: This step may take some time 
 
Step 3 . Planet Approach Correction 
14. Close External MFD and,Open as Orbit in right MFD → Ref →Mars →PRJ to get Shp →DST 
15. Target Intercept → Menu (top right) → select Planet Approach and enter  desired Eqi and PeA 
16. PG→BV→AB autoburn......wait end of burn 
 
Step 4 . Orbit Insert 
17. Planet Approach →Next →select Otbit Insert → select Apoapsis →Next → aelect Alt enter desired 

altitude (Km) →PG→BV→AB autoburn  (you may warp 1000X until end of burn) 
 

 
The message “Invalid Source or Reference” will appear when overlaping the three points 
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4. MARS TO VENUS 
 

 
 
Step 1 . Orbit Eject 
18. Left MFD →Interplanetary→Menu  →Course →Target Intercept →TGT → enter Venus →PRJ →Self 
19. Right MFD →MNU → Opmode →enter  0→Orbit Eject → Select Course →PRJ →Self 
20. Open external MFD →REF enter the Earth→FRM →Equ  → PRJ→Shp  →DST 
21. Target Intercept → Modify Tin and TEj to minimize dV (BT)  in Orbit Eject 
22. Orbit Eject  → Modify Tej to get the blue line over the green doted line (min EjA / dV) 
23. →PG → BV → AB   
24. Warp 1000X until appears ·the message ““Have a nice voyage” 
 
Step 2 . Mid Course Correction 
25. Target Intercept  →PG →Src enter X to get the vessel as source 
26. Right MFD  →MNU → Map →TGT enter Venus→Dsp → PG → Soi → Int → Plan → PG → Cnt → Sel 
27. Read PeT and warp 1000X Wait until Pet about=1/2 of initial PeT and warp 1X 
28. →PG→BV→AB autoburn  
29. Warp 100000X and wait until the Target Intercept  shows the message “Invalid Source or Reference” 
30. Note: This step may take some time 
 
Step 3 . Planet Approach Correction 
31. Close External MFD and,Open as Orbit in right MFD → Ref →Venus →PRJ to get Shp →DST 
32. Target Intercept → Menu (top right) → select Planet Approach and enter  desired Eqi and PeA 
33. PG→BV→AB autoburn......wait end of burn 
 
Step 4 . Orbit Insert 
34. Planet Approach →Next →select Otbit Insert → select Apoapsis →Next → aelect Alt enter desired 

altitude (Km) →PG→BV→AB autoburn  (you may warp 1000X until end of burn) 
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5. IO TO EUROPA 
 

 
 
Step 1 . Target In tercept 
1. Left MFD→Interplanetary →Menu  →Course → Target Intercept → TGT → enter Europa →PRJ = self 
2. Right MFD →MNU → Opmode →enter  0 →Orbit Eject → Select Course → PRJ = self 
3. Open external MFD →REF enter the Io→FRM →Equ  → PRJ→Shp  →DST 
4. Target Intercept →Z+ several times  → TOF Locked Modify →Tej to minimize dV (BT)  in Orbit Eject 
5. TOF unLocked →Modify  Tin to further modtfy dv in orbit Eject 
6. Orbit Eject  → Modify Tej to get the blue line over the green doted line (min EjA / dV) →PG → BV → AB   
7. ......wait end of burn 
 
Step 2 . Mid course correction 
8. Map →TGT= Moon →Sel→Dsp→PG→Soi →Int→Plan →PG→Sel to get Pe Ref Moon in top left corner 

→MOD 3 times to set Accurracy = 1 →MOD to return Ref Moon 
9. The white dot is our vessel  
10. Warp 10000X and when leaving the Io Soi → warp 0.01X → Scr enter X to get the vessel as source 
11. Read PeT and warp 1000X Wait until Pet=1/2 initial PeT and warp 1X →PG →BV →AB autoburn 
12. Warp 1000K until appears ·the message “Invalid Source of Reference” 
 
Step 3 . Planet Approach 
13. Close External MFD and,Open as Orbit in right MFD → Ref →target Europa →PRJ to get Shp →DST 
14. Target Intercept → Menu (top right) → select Planet Approach and enter  desired Eqi and PeA 
15. PG→BV→AB autoburn......wait end of burn 
 
Step 4 . Orbit Insert 
16. Planet Approach →Next →select Otbit Insert → REF=Planet → select Apoapsis →Next → aelect Alt 

enter desired altitude (Km) →PG→BV→AB autoburn  (you may warp 1000X until end of burn) 
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APPENDIX – GLOSSARY OF IMFD ABBREVIATIONS  
 

INTERPLANETARY PROGRAMS 
 
 

 
 
 

Map program can be used to display entire solar system and predict the actual course of the vessel with 
numerical trajectory calculator. The predictor can be also used to predict a hypothetical scenarios as well. 
 
Orbit Eject program is required when starting interplanetary missions from the orbit. This program is used in 
a combination with the other programs to convert the Escape information into burn guidance data. 
 
Course program is a collection of minor navigation programs those will let you to navigate through the solar 
system to other planets, moons and comets. Primary programs are based on the Lambert solver. In the most 
simplest case only a date of ejection and the date of arrival are required as an user input. 
 
o Target Intercept Set the course to intercept the target at the specified time or date 
o Tangential Transfer Similarly to the Target Intercept Program, but will take only one input parameter expressed in 
a two forms a time to ejection (TEj) or a MJD of ejection. 
o Planet Approach Used to change the orbit altitude and/or the equatorial inclination assuming that you 
are close to or inside the sphere of influence of the approaching body 
o Orbit Insert Used to make an orbit insertion from hyperbolic approach orbit to a low orbit around the 
reference planet 
o Delta Velocity Manual Delta Velocity tool 
 
BaseApproach The program will allow to establish an orbit right over a specific base on a planet so that it is 
possible to continue the descent on the base.. 
 
Orbital can change your orbit It has three modes: Circularise, Velocity Match, Find Target and Orbital Vel. 
Match. 
 
Sling-shot or planetary gravity assists, involves exchanging energy or momentum with a planet as a 
spacecraft flies past it. Gravity assistance can be used to accelerate, decelerate and/or re-direct the path of a 
spacecraft 
 
Surface Launch program is usefull when starting interplanetary or lunar missions from the planet surface. 
The program will compute the time to launch window and required launch heading. This program is the only 
one that doesn't compute any burn guidance data. A vessel specific ascent profile should be used to reach a 
low orbit 
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LEFT BUTTON DESCRIPTIONS 
MNU  Brings up the main menu screen of IM 
PG Cycle through pages 
REF Cycle through pages 
TGT Allows the user to set up the target body 
MOD Cycle through text modes 
PRJ Cycle through projections - Self, Ecliptic, Target, Periapsis and Equator 
 

 
 
 
 

KEY COMMANDS FOR PROGRAMS OTHER THAN MAP 
Prv Select previous variable 
Nxt Select next variable 
+,- Adjust variable 
 

Set Set variable manually 

Adj Change adjustment speed 
 

BV Open/Close burn vector display 

Z+ - Change a zoom factor 
Src Set-up source object 
Cnt Center the display in other position 
AB Enable/Disable autoburn 
 
 
 

 
 
 
 
 
 
 
 
 
 

LINES AND COLORS 
Green orbit               Current orbit of the source object 
Orange orbit            Current target orbit. 
Blue orbit                 Transfer orbit 
White line                 Intersection / interception positions and in the orbit-eject program it will show the escape      
direction 
Orange dashed line Target position at the time of intersection 
Orange dashed line Target position at the time of intersection 
Blue dashed line      Ship position at a time of interception 
Green dashed line    Position for the burn. 
 
 
 
 
 
 
 
 
 
 

INFORMATION   ITEMS 

AgP  Angle between your periapsis and your ascending node  
ApA  Altitude of the Apoapsis of the target orbit 
ApD  Radial Distance of Apoapsis 
ApT      Time to Apoapsis 
ApV      Velocity at Apoapsis 
BLL      The optimum Latitude that you should launch at 
BT  Burn time 
C3   Orbital energy of scape asymptote 
Cir  Delta Velocity required to circularize orbit 
Dis       Radial Distance from the Reference body minus initial Radial Distance from the Reference Body  
dV          Delta Velocity required for your current orbit to match the target orbit 
Ecc      Eccentricity of the target orbit. 
Ein       Relative inclination 

KEY COMMANDS FOR MAP PROGRAM 
Cnt Allows the user to set up the object that the Map Program displays at the center 
Z + - Zoom in / out on the object that is currently centered 
Sel Cycles through Periapsises or Apoapsises 
Dsp All bodies above the mass limit designated in the Map Configuration Page are displayed 
Azo Auto Zoom 
Slf Display or Hide ship‘s trajectory 
Soi Display the sphere of influence 
Int Turn Intercept Mode on or off 
Plan Switch flight planning mode on and off 
Find Cycles through all bodies in the star system displayed 
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EjA  Ejection angle 
ELa  Longitude of ascending node relative to the equator 
EqI  Equatorial Inclination 
Gap  Argument of Periapsist. This is the angle between your periapsis and your ascending node  
GET     The GET at the time which you intercept your target 
Hed The heading you should fly when you launch for orbit  
InA Intercept angle 
iV Inward Delta Velocity 
LAN Longitude of Ascending Node of your target orbit  
Lat Current latitude on surface of celestial body 
Lon Current longitude on surface of celestial body 
Max EqI Maximum Equatorial Inclination possible given all of your current parameters  
Min EqI Minimum Equatorial Inclination possible given all of your current parameters.  
Ope Orbital period 
oV Outward delta velocity, that’s the velocity added in a velocity of the planet  
PeA Altitude of Periapsis 
PeD Radial Distance of Periapsis  
PeT Time to Periapsis 
PeV Velocity at Periapsis 
PlC Delta Velocity required for the Plane Change  
PlC Delta Velocity required for the Plane Change  
PlC Delta Velocity required for the Plane Change  
Time Time in seconds until the optimum launch time  
in Time to intercepting your target. 
Tn Time to next node. When negative it is presenting the time after the node.  
Tot Total delta velocity 
 
 

 
 
 


