C++ Question Compiling SSRMS version issue

gattispilot

Addon Developer
Addon Developer
Joined
Oct 17, 2007
Messages
7,046
Reaction score
1,307
Points
203
Location
Dallas, TX
So trying to re compile the SSRMS code for another rms. I know it worked before. But I got a newer version of VS. I get this error:
Severity Code Description Project Path File Line Suppression State
Error LNK2038 mismatch detected for '_MSC_VER': value '1800' doesn't match value '1900' in LEESystem.obj DEXTREARM D:\Orbiter2016\Orbitersdk\samples\DextreARM2 D:\Orbiter2016\Orbitersdk\samples\DextreARM2\libUltra.lib(UltraMath.obj) 1
another but it might fix its self

Severity Code Description Project Path File Line Suppression State
Error LNK2019 unresolved external symbol "__declspec(dllimport) char const * __cdecl std::Winerror_map(int)" (__imp[email protected]@@[email protected]) referenced in function "public: virtual class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > __thiscall std::_System_error_category::message(int)const " ([email protected][email protected]@@[email protected][email protected]@[email protected]@[email protected]@[email protected]@[email protected]@Z) DEXTREARM D:\Orbiter2016\Orbitersdk\samples\DextreARM2 D:\Orbiter2016\Orbitersdk\samples\DextreARM2\libUltra.lib(UltraMath.obj) 1

how to fix?
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,808
Reaction score
325
Points
83
Have you tried "google"ing? And thinking a bit more about it?
It should not be to hard for you to figure out by yourself, that libUltra.lib somehow likes to be linked with MSC Version "1900" while your LEESystem.obj uses MSC Version "1800".
How to fix it? Make sure everything is compiled with the same setup; look why libUltra.lib needs '1800' (somewhere _MSC_VER is defined as being 1800, either as a #define preprocessor statement or as a compile time option).
Again: Try to figure out things by yourself! It takes longer, yes. But you learn much much more!
 

gattispilot

Addon Developer
Addon Developer
Joined
Oct 17, 2007
Messages
7,046
Reaction score
1,307
Points
203
Location
Dallas, TX
Thanks. I guess I need to compile SSU under Microsoft Visual Studio Community 2019. Then It might work. SSRMS is part of SSU
 
Top