Error D3D9 Client error on O2010p1: The procedure entry point ?ElevationGrid@GraphicsCli...

8bitgamer13

New member
Joined
Jan 15, 2016
Messages
116
Reaction score
1
Points
0
Hi, I've been having some problems with D3D9-
After having installed it, I opened up Orbiter_ng.exe and went to activate the module. When I did that, however, I was greeted with a dialog presenting me with the following error:

"The procedure entry point ?ElevationGrid@GraphicsClient@oapi@@QBE_NPAXHHHHHHPAF1PAN@Z could not be located in the dynamic link library Orbiter.exe"

It didn't CTD, but I exited out and went to open it up again. Now, whenever I open Orbiter_ng.exe, it starts up fairly normally save for the fact that I always get that same dialog, and don't get the D3D9 "Video" control tab. What's going on?
 

8bitgamer13

New member
Joined
Jan 15, 2016
Messages
116
Reaction score
1
Points
0
Upgrade? I'm currently using D3D9Client 2016 Edition R2.1, which is the latest version.
EDIT-
Hold on- it seems that's for Orbiter 2016. I'll try the R15 version.
EDIT 2- It's working now- thanks.
 
Last edited:

Ripley

Tutorial translator
Donator
Joined
Sep 12, 2010
Messages
3,125
Reaction score
400
Points
123
Location
Rome
Website
www.tuttovola.org
Glad it works, but I meant your DirectX9 Windows libraries, not the D3D9Client.

---------- Post added at 22:02 ---------- Previous post was at 21:54 ----------

After searching the forum for "procedure entry point", it sounds as if the error originates from mismatched versions, as in your original post (O2010-P1 and D3D9Client for O2016), and not from an outdated DirectX9.
 
Top