OHM DG-Launcher (Russian Federation) v1.02

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
9,256
Reaction score
3,229
Points
203
Location
Toulouse
I'm not sure, I usually check this, but I might have forgotten. I will try that, thanks.
 

Wonderer

New member
Joined
Jan 15, 2010
Messages
192
Reaction score
0
Points
0
The problem with the SMOKE_GEN modules is most likely that they were compiled in DEBUG mode rather than RELEASE mode, causing them to depend to rely on debug versions of their dependencies.

A quick recompile of the modules in RELEASE mode ought to fix it.

For now a download of MSVCR90D.dll should fix the problem temporarily: http://www.dll-files.com/dllindex/dll-files.shtml?msvcr90d

Didn't work-still no smoke for me :beathead:
 

DaveS

Addon Developer
Addon Developer
Donator
Beta Tester
Joined
Feb 4, 2008
Messages
9,423
Reaction score
677
Points
203
Didn't work-still no smoke for me :beathead:
Did you try putting the MSVCR90D.dll file in your root Orbiter folder? That usually clears up any dependency problems for me.
 

Usquanigo

New member
Joined
Dec 18, 2008
Messages
487
Reaction score
0
Points
0
Website
uk.groups.yahoo.com
There might be something to that.

I just tried the test Atlantis Velcro mission and there was no SRB smoke, just a weird exhaust texture I've never seen before.
 

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
9,256
Reaction score
3,229
Points
203
Location
Toulouse
Could it possibly be a bug in Velcro rockets caused by Orbiter 2010?
Let's be clear, you don't have particle effects using Velcro Rockets under Orbiter 2010. It's why I needed additionnal .dll modules (implemented in the scenarios as dummy invisible & almost weightless ships) to bypass that limitation. Recompiled "release" .dll will be available in next versions (1.01 for the russian DGL).

---------- Post added at 07:25 PM ---------- Previous post was at 05:16 PM ----------

Ok guys, I've recompiled the 2 DLLs following step by step Computerex :)hail:) instructions given in the part 1 of the BombMFD tutorial. Still works very well on my comp, I hope it will work for everybody now. The .dll are three times bigger than before (60k vs 20k), so I guess there are more "materials" inside...

[ame="http://www.orbithangar.com/searchid.php?ID=4758"]DG-Launcher (Russian Federation v1.01)[/ame]

(don't forget to click "Yes", overwrite all when you unzip the files ;))
 
Last edited:

Usquanigo

New member
Joined
Dec 18, 2008
Messages
487
Reaction score
0
Points
0
Website
uk.groups.yahoo.com
:thumbup:

That's got it. At least for down in the lower atmosphere. I didn't have time to watch it all the way out into space, but now, once it got off the ground, there was a spray of particles and particle exhaust as one would expect, and it looks good too. Thanks. :)
 

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
9,256
Reaction score
3,229
Points
203
Location
Toulouse
AAh, these are excellent news !!! :speakcool:

Watch out for a v1.02 update of the NA Launcher this week, it seems that it's exactly the same issue ;)
 

Wonderer

New member
Joined
Jan 15, 2010
Messages
192
Reaction score
0
Points
0
Who cares about lift off when we have smoke :woohoo:

For me it works all the way to orbit :)
 

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
9,256
Reaction score
3,229
Points
203
Location
Toulouse
Now updated to v1.02, should be Orbiter 2010-P1 compatible. Please let me know if you encounter problems (don't forget the Orbiter.log). :tiphat:
 

Caine

New member
Joined
Feb 14, 2011
Messages
1
Reaction score
0
Points
0
particleGEN

First of all, great work, thanks :thumbup:

got a little issue with the particleGEN, whenever I raise the PADBIAS on the core unit to put it on a launchpad the smoke starts as soon as I load the scenario, any way to avoid that?
Same with the US-launcher.

Otherwise works perfect for me.
 

Geo

New member
Joined
Feb 19, 2012
Messages
13
Reaction score
0
Points
0
Location
Vaison la Romaine, southern France
I donwloaded this addon few weeks ago. A must have!
But now I have some problems: when I want to change the place of the launcher+DGIV, the rocket ignite but does not liftoff.

Do you know where does it comes from?

Thanks you!
 

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
9,256
Reaction score
3,229
Points
203
Location
Toulouse
I'm going to update that one too, especially since DanSteph will release a D3D9 compatible version of the DG-IV. Quite overloaded right now, but I don't forget it ! ;)
 

OrbiterSpore

Clean Furry, of A Dying Breed
Joined
Sep 26, 2010
Messages
269
Reaction score
0
Points
0
Location
<<CLASSIFIED>>
Website
steamcommunity.com
Hello.
I'd like to ask something.
I'm getting some very low FPS during the very start of the launch. When the camera doesn't show the DGL-BlockB, it has good FPS (35-50 >), but as it starts showing DGL-BlockB, the FPS drops to charming < 7 FPS.

Computer specs:Windows 7, 4 GB RAM, Intel Dual Core Celeron CPU E3200 @ 2.40GHz and 2.40GHz, nVidia GeForce 9500 GT

Is there anything i can do?
 

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
9,256
Reaction score
3,229
Points
203
Location
Toulouse
I assume you are using the D3D7 inline client (for DGIV compatibility) ?

The problem is that my models were quite poly-heavy. It should run flawlessly with the D3D9 Client though. Notice that DanSteph said he would fix the DG-IV to make it D3D9-compatible. That would be the best possible fix. ;)

What I can suggest is to use the XR-1 instead, while we wait for that fix. Yes I know, its not the same ship, but...
 
Last edited:
Top