Problem Lunar Mesh Textures don't load and other problems (2010)

2Copernicus

New member
Joined
Aug 14, 2022
Messages
16
Reaction score
11
Points
3
Location
Earth
Hi.

So at the moment I'm working on my first lunar mesh for orbiter 2010 and it came with a few problems.

So I basically put the DG landed at where I want the scenery, then I add the scenery to the area as a vessel and as landed via the scenario editor (to allow for easier testing).

orbiter-2022-09-24-15-20-56-56.jpg

Orbiter Forum.JPG
When I add the scenery the general landscape is fine, but the craters are pure black and don't seem to have their appropriate textures.

The second issue with the mesh seems to be that the bounding box is way too thick, I designed the mesh in Blender as a plane, but there seems to be a fair amount of thickness in orbiter, leading to the DG kind of sinking partially through it.

orbiter-2022-09-24-15-21-03-53.jpg

As a final question, does anyone know if there is a tutorial or general guide for dealing with the curvature of the moon for the mesh? At the moment I can't think of any immediate way around it, and as the moon curves the DG starts to sink even further into it.

Thanks for the help on all this as I'm extremely new to blender and orbiter development in general.

Attached is the mesh file. I created it using the blender to orbiter mesh converter for blender 2.78.
 

Attachments

  • 40NWRosse.txt
    2.2 MB · Views: 8

barrygolden

Well-known member
Joined
Nov 3, 2009
Messages
701
Reaction score
110
Points
58
Location
North of Houston
4th rock is the guy to talk too about new Landing sites he did Apollo 18,19 and 20 with features to explore 2016 could use some too
 

BrianJ

Addon Developer
Addon Developer
Joined
Apr 19, 2008
Messages
1,533
Reaction score
664
Points
128
Location
Code 347
Hi,
its been a while since I used Orbiter2010!
But I notice the first group in your mesh has no Texture UV coordinates - you'd need to add them in Blender, I guess.
This might be your "black crater" problem - or you might be having trouble with shadowing.
Add the line
FLAG 0x00000001
to your mesh group after the TEXTURE entry to disable shadowing by that group.

Good luck!
BrianJ
 

2Copernicus

New member
Joined
Aug 14, 2022
Messages
16
Reaction score
11
Points
3
Location
Earth
Hi,
its been a while since I used Orbiter2010!
But I notice the first group in your mesh has no Texture UV coordinates - you'd need to add them in Blender, I guess.
This might be your "black crater" problem - or you might be having trouble with shadowing.
Add the line
FLAG 0x00000001
to your mesh group after the TEXTURE entry to disable shadowing by that group.

Good luck!
BrianJ
Hi

Thanks for the help and I am gonna try it. But I do have one question?

I didn't use UV mapping on the textures since I'm really not that good at it, and assumed that UV or global or object wouldn't make a difference to orbiter, since it looked fine in blender. When you say use UV do you mean for the flatland (i.e not the black craters) or for both the flatland and the craters?

Only reason I ask is the issue I have is when using UV for the craters it starts creating distortion in the texture itself, so that's why I used global and changed the size setting to something that looked manageable.

Again thanks for the help, I'm just really new to this, so a lot of stuff is well..... new. :)
 

BrianJ

Addon Developer
Addon Developer
Joined
Apr 19, 2008
Messages
1,533
Reaction score
664
Points
128
Location
Code 347
Hi,
I'm not a Blender user, so can't really help with adding Texture UV coordinates in Blender - but I'm sure some of the folks here can probably help with that.
Again thanks for the help, I'm just really new to this, so a lot of stuff is well..... new. :)
You're welcome - you gotta start somewhere!
BrianJ
 

2Copernicus

New member
Joined
Aug 14, 2022
Messages
16
Reaction score
11
Points
3
Location
Earth
Hi,
its been a while since I used Orbiter2010!
But I notice the first group in your mesh has no Texture UV coordinates - you'd need to add them in Blender, I guess.
This might be your "black crater" problem - or you might be having trouble with shadowing.
Add the line
FLAG 0x00000001
to your mesh group after the TEXTURE entry to disable shadowing by that group.

Good luck!
BrianJ
I assume you mean like this to the mesh file?
MSHX1
GROUPS 2
LABEL Craters
MATERIAL 1
TEXTURE 1
FLAG 0x00000001
If so, tried it and still no luck :(. I'm wondering whether it just relates to the texture I'm using, so I'll try replacing that texture with another one and see how it works out, hopefully it does.
 

Jordan

Active member
Joined
May 13, 2010
Messages
96
Reaction score
28
Points
33
Location
Germany
@2Copernicus
Your craters definitely don't have UV's. The landscape does.
This is what I see when I import your mesh into Blender.
 

2Copernicus

New member
Joined
Aug 14, 2022
Messages
16
Reaction score
11
Points
3
Location
Earth
@2Copernicus
Your craters definitely don't have UV's. The landscape does.
This is what I see when I import your mesh into Blender.
I honestly didn’t think that a UV was strictly needed for textures, i guess I’ll try to convert the craters to having a UV texture, though that unfortunately leads to distortion last I tried. Would you happen to know a decent tutorial for blender 2.78 UV mapping? My searches have been a tad unfruitful.
 

llarian

Well-known member
Joined
Apr 1, 2009
Messages
540
Reaction score
128
Points
58
Location
Ottawa
I honestly didn’t think that a UV was strictly needed for textures, i guess I’ll try to convert the craters to having a UV texture, though that unfortunately leads to distortion last I tried. Would you happen to know a decent tutorial for blender 2.78 UV mapping? My searches have been a tad unfruitful.
You might be better served if you use a more recent version of Blender. There have been substantial improvements in UV handling. The latest LTS version of Blender is 3.3.
 

Jordan

Active member
Joined
May 13, 2010
Messages
96
Reaction score
28
Points
33
Location
Germany
@2Copernicus
Load your mesh in Blender

Switch Blender from "Default" to "UV Editing" top Bar.

The following is in the "3D View" Window. Default is right side.
Move the mouse in the 3D window and press the "7" key in the numberpad (right side of your keyboard). You may also press the "5" key to switch to the orthographic view. You can check that in the top left of the 3D view. It should say "Top Ortho".
Now select the craters and switch from "Object Mode" to "Edit Mode" in the bar below
Press the "A" key 1 or 2 times until everything is selected. Then press "U" and in the UV mapping menu select "Project From View"

The following is in the "UV Editing" Window. Default is left side.
In the left UV window you will see the craters that are now UV unwrapped.
Also In the left UV window to the left of the "New" "Open" icons, click on the "Image" icon and choose your crater texture. You may have to load them with "Open".
Then press 1 or 2 times the "A" key in the UV window until nothing is selected.
Then move your mouse over each individual crater and press the "L" key, so you select individual craters which you can then adjust to your texture by dragging (G), scaling(S) or rotating(R).
Press "A" again until nothing is selected and continue with next Crater.
After that you can export your mesh.

Zoom in and out with the mouse wheel if you can't see your entire mesh. With "SHIFT & middle mouse button" you can pan the view.

I hope I helped you.
 

2Copernicus

New member
Joined
Aug 14, 2022
Messages
16
Reaction score
11
Points
3
Location
Earth
@2Copernicus
Load your mesh in Blender

Switch Blender from "Default" to "UV Editing" top Bar.

The following is in the "3D View" Window. Default is right side.
Move the mouse in the 3D window and press the "7" key in the numberpad (right side of your keyboard). You may also press the "5" key to switch to the orthographic view. You can check that in the top left of the 3D view. It should say "Top Ortho".
Now select the craters and switch from "Object Mode" to "Edit Mode" in the bar below
Press the "A" key 1 or 2 times until everything is selected. Then press "U" and in the UV mapping menu select "Project From View"

The following is in the "UV Editing" Window. Default is left side.
In the left UV window you will see the craters that are now UV unwrapped.
Also In the left UV window to the left of the "New" "Open" icons, click on the "Image" icon and choose your crater texture. You may have to load them with "Open".
Then press 1 or 2 times the "A" key in the UV window until nothing is selected.
Then move your mouse over each individual crater and press the "L" key, so you select individual craters which you can then adjust to your texture by dragging (G), scaling(S) or rotating(R).
Press "A" again until nothing is selected and continue with next Crater.
After that you can export your mesh.

Zoom in and out with the mouse wheel if you can't see your entire mesh. With "SHIFT & middle mouse button" you can pan the view.

I hope I helped you.
It did help, and it worked! The craters now finally have textures! TY so much.

And I understand just a tiny bit about UV mapping now :).

Any way for me to set this thread as solved?
 

Jordan

Active member
Joined
May 13, 2010
Messages
96
Reaction score
28
Points
33
Location
Germany
@2Copernicus
It did help, and it worked! The craters now finally have textures! TY so much.
You're welcome

And I understand just a tiny bit about UV mapping now
Yes, if you are new, the topic is a bit complicated.

Any way for me to set this thread as solved?
I don't think that's necessary

By the way, as @llarian wrote, it is better to use the newer version of Blender.
The exporter works a little "differently" but once you get used to it, you don't want to miss it.
You can use both together and see what suits you more
But remember, what you are using now, will not be developed further.
 

2Copernicus

New member
Joined
Aug 14, 2022
Messages
16
Reaction score
11
Points
3
Location
Earth
@2Copernicus

You're welcome


Yes, if you are new, the topic is a bit complicated.


I don't think that's necessary

By the way, as @llarian wrote, it is better to use the newer version of Blender.
The exporter works a little "differently" but once you get used to it, you don't want to miss it.
You can use both together and see what suits you more
But remember, what you are using now, will not be developed further.
Hi.

I'd love to use newer versions of blender, the main problem is I'm using windows 7 and the newer versions of blender require newer versions of windows to my knowledge.

I guess I have a few more questions, I'm trying to remove the shiny nature of the surface, just not entirely sure how. Its modifications to diffuse and spectacular in blender I believe?

A second question is I'm actually wondering if instead of making the surface all a vessel, if it would make more sense to make the general surface (not the craters) a surface tile instead. I tried it, but so far it's not registering the texture even though the file should make sense.

Name of Texture: Moon_1_E0780_S0396
And base config:
(and I do know that the base config has to be .cfg, I just changed it so forum would recognize it)
One thing that it could be though I'm not sure is that the base texture is 8mb large. Perhaps that's too big?
 

Attachments

  • 40NWRosse.txt
    227 bytes · Views: 4
Last edited:

Jordan

Active member
Joined
May 13, 2010
Messages
96
Reaction score
28
Points
33
Location
Germany
@2Copernicus
I guess I have a few more questions, I'm trying to remove the shiny nature of the surface, just not entirely sure how. Its modifications to diffuse and spectacular in blender I believe?
Try it by setting the Specular intensity to zero in the material settings.

A second question is I'm actually wondering if instead of making the surface all a vessel, if it would make more sense to make the general surface (not the craters) a surface tile instead. I tried it, but so far it's not registering the texture even though the file should make sense.
Sorry, i don't know how this works.

I'd love to use newer versions of blender, the main problem is I'm using windows 7 and the newer versions of blender require newer versions of windows to my knowledge.
You could use this version, get the .zip file. This should be the last official Window 7 version.
https://download.blender.org/release/Blender2.92/

You will need Blake's Orbiter Mesh Tools for this.
He also has a tutorial in the zip file which is very helpful.
https://github.com/BMCDad/orbiter-blender/releases

Why are you still using the Orbiter 2010 version? The 2016 is way better.
You can also test this beta version of Orbiter 2016
https://www.orbiter-forum.com/resources/orbiter-beta-r90.954/

And the matching D3D9 client version
http://users.kymp.net/~p501474a/D3D9Client/D3D9ClientBeta30.7-forBETA r90(r1436).zip

And here you can find the HighRes Planet textures
http://orbit.medphys.ucl.ac.uk/mirrors/orbiter_radio/tex_mirror.html
 
Last edited:

2Copernicus

New member
Joined
Aug 14, 2022
Messages
16
Reaction score
11
Points
3
Location
Earth
@2Copernicus

Try it by setting the Specular intensity to zero in the material settings.


Sorry, i don't know how this works.


You could use this version, get the .zip file. This should be the last official Window 7 version.
https://download.blender.org/release/Blender2.92/

You will need Blake's Orbiter Mesh Tools for this.
He also has a tutorial in the zip file which is very helpful.
https://github.com/BMCDad/orbiter-blender/releases

Why are you still using the Orbiter 2010 version? The 2016 is way better.
You can also test this beta version of Orbiter 2016
https://www.orbiter-forum.com/resources/orbiter-beta-r90.954/

And the matching D3D9 client version
http://users.kymp.net/~p501474a/D3D9Client/D3D9ClientBeta30.7-forBETA r90(r1436).zip

And here you can find the HighRes Planet textures
http://orbit.medphys.ucl.ac.uk/mirrors/orbiter_radio/tex_mirror.html
I have started to use 2016, its just from what I understand scenery making in 2016 is infinitely harder than it is in 2010, so I thought I'd start slow on the development and build up from there, as with 2016 I don't even really know where to start.

Ty for the blender and help with the specular, I'll try em out.
 
Top