Announcement OHM - Deployments, and fixes

Xyon

Puts the Fun in Dysfunctional
Administrator
Moderator
Addon Developer
Webmaster
GFX Staff
Donator
Beta Tester
Joined
Aug 9, 2009
Messages
6,691
Reaction score
203
Points
153
Location
10.0.0.1
Website
www.orbiter-radio.co.uk
Hello again Orbinauts!

I thought now would be a good time to share with you some of the work that's been happening behind the scenes as I prepare to deploy what will ultimately become the replacement for the ageing OrbitHangar Mods site.

Firstly, this hasn't been an entirely solo affair, notable contributions from IronRain and tl8 have also driven the projects to their current state, so I'd like to extend them my gratitude too. This has been a pet project of mine for some while now, and I'm really grateful for the assistance in getting things over the line.

What?

The Orbit Hangar Mods site will be replaced, in stages, beginning with phase 1 this Friday (as per the notice). The site will shift from being a monolithic direct-access frontend to a loosely coupled frontend backed by a REST API, which will allow for easier integration with other systems and services, centred around the upcoming work to also bring Orbiter Forum up to date.

Stage 1 will link several elements of the existing frontend, bridged by modern components and logic, to the new backend. Stage 2 will involve an entire interface overhaul on the frontend, which will contain several visual and layout changes.

Why?

First, OHM is currently badly broken, most notably when you try to submit a new addon. Some of the reasons for why this is I have already been through, but the short version is, the site needed some intensive work and effort to bring it back to a point where it could function on the current technology platform (with noted security fixes), and then to improve some long-standing issues that have often been significantly limiting for end-users. The new site utilises Digital Ocean's geo-CDN caching for addon assets, meaning wherever you are in the world, the asset should be somewhere vaguely near to you - definitely closer to users in APAC than they have been up until this point.

The REST API is the central technology, and I've been writing it on and off in Rust for the best part of three years, if my git commit history is to be believed. It's an ongoing labour of love, but crucially is also licensed under the GNU GPL v3 license, and the source code is open to those who wish to view it. It's my hope this will encourage contribution, and perhaps in time to transform the project from a personal endeavour into a community project - to avoid the code languishing in the future, as the old site did.

You guys all deserve a decent addon repository site, and it's been a lot of fun (and some frustration) to make it. You can get a feel for how the site will work after Friday's work by viewing the staging site, at https://preflight.orbithangar.com.

When?

Phase 1 I have scheduled in for 2020-01-31 at 20:00 UTC. I'll have to make the old OHM unavailable for a short while so I can migrate the data in the existing database into the new format required for the API and core libraries. It shouldn't take too long, but to be on the safe side I've estimated the window will be 2 hours wide.

As for Phase 2, things aren't quite as ready to go on the frontend side just yet, but restoring site functions via Phase 1 gives us more time to make sure the frontend replacement is fully ready before we ship it out.

What else?

It's important to note that the Phase 1 is a temporary bridge, and it's not a perfect replacement - there are still some rough edges, but the core functions of the site work as expected, and I'm keen to get them back up so the site can be used properly again. I will continue to address issues in the Phase 1 site while working alongside the other developers on Phase 2, and hopefully we'll have something exciting to deliver very soon!

As always, thanks for your continued support. Once Phase 1 is deployed, my focus will shift short-term towards the Xenforo migration for the main board, which we can then develop against for the OHM API and the new frontend.

Thanks for reading, and happy orbiting!
 

kuddel

Donator
Donator
Joined
Apr 1, 2008
Messages
1,775
Reaction score
277
Points
83
Thanks for your effort! :thumbup:
 

llarian

Active member
Joined
Apr 1, 2009
Messages
467
Reaction score
31
Points
43
Location
Ottawa
How is the migration going?

Hi guys, how is the migration going. I'm probably being a bit premature but I cannot even get into it at this time. It keeps thinking I'm new. If I try to link from the forum it asks for my forum ID number which I can't seem to access.

Should I leave it alone for now or can you PM my ID number so that I can try it out for you?

Good luck

Llarian (Ken Carter)
 

gattispilot

Addon Developer
Addon Developer
Joined
Oct 17, 2007
Messages
6,696
Reaction score
956
Points
203
Location
Dallas, TX
Weird. So when I search on it. It keeps going to my login page
 

llarian

Active member
Joined
Apr 1, 2009
Messages
467
Reaction score
31
Points
43
Location
Ottawa
I think it answers my original question. Patience is.

Good luck on progress, folks.
 

Xyon

Puts the Fun in Dysfunctional
Administrator
Moderator
Addon Developer
Webmaster
GFX Staff
Donator
Beta Tester
Joined
Aug 9, 2009
Messages
6,691
Reaction score
203
Points
153
Location
10.0.0.1
Website
www.orbiter-radio.co.uk
Patience is appreciated, but if you're having specific issues, do look over in the Orbit Hangar project here on OF to report new ones or extend the information available on existing ones. I'm aware there are some issues with it as things are, but (to a certain extent) the more input I have, the better.
 

llarian

Active member
Joined
Apr 1, 2009
Messages
467
Reaction score
31
Points
43
Location
Ottawa
Okay Xyon, here are some screen grabs to take a look at.

When I first select OH from my browser, this is what I see: grab_003


When I log in as llarian (my usual OF login), it transfers me to the screen you see in grab_004. I think I've been around quite awhile.

Just trying to login with what I first see at OH sends me to the screen you see in gab_005.

Regardless of the approach I can access nothing else in OH.

grab_003.jpg

grab_004.jpg

grab_005.jpg
 

Xyon

Puts the Fun in Dysfunctional
Administrator
Moderator
Addon Developer
Webmaster
GFX Staff
Donator
Beta Tester
Joined
Aug 9, 2009
Messages
6,691
Reaction score
203
Points
153
Location
10.0.0.1
Website
www.orbiter-radio.co.uk
The three of you are fairly longstanding members. Did you have OHM accounts from before the two were "merged" a few years ago?
 

gattispilot

Addon Developer
Addon Developer
Joined
Oct 17, 2007
Messages
6,696
Reaction score
956
Points
203
Location
Dallas, TX
Not sure what you are asking? But I think the answer for me is yes.
 

Xyon

Puts the Fun in Dysfunctional
Administrator
Moderator
Addon Developer
Webmaster
GFX Staff
Donator
Beta Tester
Joined
Aug 9, 2009
Messages
6,691
Reaction score
203
Points
153
Location
10.0.0.1
Website
www.orbiter-radio.co.uk
Not sure what you are asking? But I think the answer for me is yes.


Okay, some context; Back in 2009, Vash altered how OHM authentication was handled.



Before this change, OHM and OF had entirely separate user records, and folk had accounts in both systems.


After this change, new accounts were slaved to the forum, meaning no new registrations were accepted on OHM (with some exceptions, but let's pretend that didn't happen for now). Users with an old-style OHM login were still able to log in.


So, if you had an account with OHM before 2009, the chances are you existed in both databases, and you were actually relying on the user information in the OHM database, which I didn't bring over (intentionally).


The solution, if you can call it that, is to try to log in to the new site with your current Orbiter Forum account details. The site should realise it hasn't seen you before, and try to make a new account for you in the API, asking you to confirm your identity by giving it your Orbiter Forum account ID so it can link the two records together.


It's a bit ham-fisted, and it will change again in the future. The reason I've had to smush things together this way is there's no API for the forum, so the lookup is achieved using a database query just like the old OHM site used to (but with modern, SQL-injection-proof code).


The difficulty comes from the tool I wrote to handle moving old data into the new format. It made user records where it found an addon by a user it didn't already have in the OHM database - some of which were new-fangled OF users with an OF ID already recorded, who should have no trouble logging in, and some who weren't. Those who didn't already have an OF ID set against your OHM account will have an OF ID of 9999 recorded, and the authentication lookup will fail to match your password hash to the vBulletin one, and you'll be told your login is invalid (when I write an error message on that page, currently it just sets invalid=true in the URL).


I'm sorry this is the way it is. Handling the data has been really tricky, and the authentication has been the hardest element of the problem to solve because of how I want to do things in the future and how they were handled in the past.


You've all been really patient with the site and I really appreciate it, I'm working on getting the issues sorted out!
 

DaveS

Space Shuttle Ultra Project co-developer
Addon Developer
Donator
Beta Tester
Joined
Feb 4, 2008
Messages
9,119
Reaction score
394
Points
173
I can't log in and I'm 100% certain that I made the OHM/O-F account merge. I just get the log in page itself, even with the correct credentials, nothing changes.
 

Blake

Addon Developer
Addon Developer
Joined
Mar 9, 2009
Messages
174
Reaction score
35
Points
43
The three of you are fairly longstanding members. Did you have OHM accounts from before the two were "merged" a few years ago?

I've had my OHM account for about 4-5 years I would say. Possibly longer.

It's not a big deal and I realize you are working on this. Thank you again for all your efforts on behalf of the community.
 

4throck

Enthusiast !
Joined
Jun 19, 2008
Messages
3,304
Reaction score
571
Points
153
Location
Lisbon
Website
orbiterspaceport.blogspot.com
I too can't login.

» Tried the forum login and I get"Greetings, traveller! Doesn't look like we've seen you round these parts before." Link account throws an error.
» Tried the older Orbiter Hangar login and no luck it just reloads the login screen.
 

llarian

Active member
Joined
Apr 1, 2009
Messages
467
Reaction score
31
Points
43
Location
Ottawa
Xyon, I think I located my OF id number. When I try to login to OH with my current OF login it sends me to the page requesting my ID number. When I hit the button to link accounts, I get this error:

"OHM API Error
An issue has been detected and the API for OHM could not be reached. This is a critical error and we unfortunately can't process your request right now. Although this incident is automatically monitored, please feel free to alert the site administrators if you've been directed to this page."
 

Ripley

Tutorial translator
Donator
Joined
Sep 12, 2010
Messages
2,984
Reaction score
230
Points
78
Location
Rome
Website
www.tuttovola.org
...So, if you had an account with OHM before 2009...
I discovered Orbiter in 2010, so no chance of a prior OH account...

---------- Post added at 16:39 ---------- Previous post was at 16:30 ----------

It's still a NO-GO for me.
OH keeps asking me the same Orbiter Forum password, which I enter indeed.
It's one of those "paranoid complex" passwords, with upper/lower case, numbers, signs, parenthesis, and what not...
 

predattak

Well-known member
Joined
Apr 4, 2013
Messages
52
Reaction score
103
Points
48
⚫When i try to log in it keeps telling me that i need an account ( the Greetings,
traveller! scenario )
⚫When i browse any categories it hits me with "File not found."
⚫And when i search it tells me that i need to log in.

Not complaining or anything of that sort just reporting that it doesn't work on my end too.

Good luck with your progress.:hide:
 
Top