Problem Several MFD addons (not included in the Github repository) do not work in a fresh Open Orbiter release

yitianetie

Member
Joined
Mar 24, 2020
Messages
53
Reaction score
18
Points
23
Location
Brittany
Hi,

It was a long time since I did not come back on this forum. I have successfully compiled Orbiter with Visual Studio 2022 but I can't run any new MFD (like IMFD for example). Is there any procedure for installing add-ons MFD. As for example, for IMFD, I have just dropped the files in the Orbiter folder (like for 2016 version) and enabled IMFD in the modules. But I cannot see the IMFD in the MFD menus. I have attached a log to this message where I get an error while trying to load new MFDs.

I am wondering if the issue is linked to a VS2022 missing library. In that case, which components do I need to install ? The explanations on GitHub repository are not very precise in this matter. Or maybe I need to install VS2019 only ? I could try to install Microsoft Visual C++ Redistributable but I am not sure to solve the problem.

I have also attached a Cmake log (partly in french, sorry) from VS2022.


Thanks in advance for your help.
Warmest regards
 

Attachments

  • Orbiter.log
    14 KB · Views: 0
  • VS2022_cmake_log.txt
    10.7 KB · Views: 1

yitianetie

Member
Joined
Mar 24, 2020
Messages
53
Reaction score
18
Points
23
Location
Brittany
Finally. I understand that a lot of MFDs are simply not compatible with last orbiter release. Some of them (the most useful) need to be recompiled against the last version.
 
Top