Problem XR vessels load at an angle on the ground

Cris

New member
Joined
Jan 11, 2010
Messages
13
Reaction score
1
Points
3
Hello,

Everytime i load a scenario with an XR vessel on the ground it's always at a weird angle. This includes the default scenarios that come with the addon, and any quicksaves or saves i made after setting the ship level. Also, if i start the scenario paused, the ship is level. But after i hit play, the ship flips on its side. This only happens with the XR series. The DGIV and the default DG are fine. Can't figure out what the issue is.

I'm using the latest version of Orbiter2016 (v.190914), and the latest version of XR from https://www.alteaaerospace.com/index-3.html
 

dbeachy1

O-F Administrator
Administrator
Orbiter Contributor
Addon Developer
Donator
Beta Tester
Joined
Jan 14, 2008
Messages
9,011
Reaction score
1,123
Points
203
Location
VA
Website
alteaaerospace.com
Preferred Pronouns
He/Him
I would retest in a clean Orbiter 2016 installation folder with only XRSound and the XR vessel(s), as it is likely that another add-on is causing this.
 

Cris

New member
Joined
Jan 11, 2010
Messages
13
Reaction score
1
Points
3
I would retest in a clean Orbiter 2016 installation folder with only XRSound and the XR vessel(s), as it is likely that another add-on is causing this.
Thanks for the reply.

Looks like it works fine in the standard Orbiter 2016 installation, but it still starts on one side in a clean beta install, with just the d3d9 module, XRSound and the XR2.
 

dbeachy1

O-F Administrator
Administrator
Orbiter Contributor
Addon Developer
Donator
Beta Tester
Joined
Jan 14, 2008
Messages
9,011
Reaction score
1,123
Points
203
Location
VA
Website
alteaaerospace.com
Preferred Pronouns
He/Him
The XR vessels were built using the publicly released Orbiter 2016, not the Orbiter beta, so it is normal that they don't work correctly running under the Orbiter beta. That would require a new build of the XR vessels compiled against the Orbiter beta, and those versions have not been built yet. :)
 

Cris

New member
Joined
Jan 11, 2010
Messages
13
Reaction score
1
Points
3
The XR vessels were built using the publicly released Orbiter 2016, not the Orbiter beta, so it is normal that they don't work correctly running under the Orbiter beta. That would require a new build of the XR vessels compiled against the Orbiter beta, and those versions have not been built yet. :)
Yeah, i was afraid that would be the case... Well, luckily, it's more of an annoyance than anything else. It doesn't break the ship sitting like that on the ground, and it doesn't look like it changes attitude when not on the ground. So... if you ever decide to patch them for the beta version... :) Thanks for the help.
 

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
7,967
Reaction score
1,049
Points
188
Location
Toulouse
Note that the Orbiter 2016 SDK documentation states somewhere that addon modules should be compiled for the 2016 version, not the beta version. So expect most 2016 addons to be compiled for the 2016 release and not the later beta version. Of course there are exceptions, but then that's the addon dev responsability to mention his module works with 2016 beta.
 

Abdullah Radwan

Addon Developer
Addon Developer
Joined
Aug 20, 2017
Messages
242
Reaction score
86
Points
43
Location
Cairo
The problem is that there is a bug in Orbiter 2016 that prevents the vessel from resting on the ground even if fully stopped. This will cause the vessel to do funny stuff with time acceleration, as Orbiter assumes the vessel is still moving, not landed. This bug was fixed in Orbiter Beta.

To fix this bug in Orbiter 2016, many addon developers (including @dbeachy1) made a code that forces the vessel to be landed in certain conditions (parking brake in XR-2 case). This code works well in Orbiter 2016, but it causes this behavior in Orbiter Beta.

To solve the problem, simply disable the parking brake in XR-2 configuration file by setting EnableParkingBrakes to 0. This should have no side effects as the bug was fixed in Orbiter Beta.
 

Cris

New member
Joined
Jan 11, 2010
Messages
13
Reaction score
1
Points
3
To solve the problem, simply disable the parking brake in XR-2 configuration file by setting EnableParkingBrakes to 0. This should have no side effects as the bug was fixed in Orbiter Beta.
Great idea! Thanks!
 
Top