Apollo 11 LOI Issue

indy91

Addon Developer
Addon Developer
Joined
Oct 26, 2011
Messages
994
Reaction score
288
Points
78
Ok, I can replicate the behavior as you have described it. I think I know what causes it, the desired REFSMMAT stored in the computer is bad. The desired REFSMMAT is the REFSMMAT (https://en.wikipedia.org/wiki/REFSMMAT) that defines the IMU alignment after the P52 option 1. It replaces the current REFSMMAT during the P52. This desired REFSMMAT was uplinked a bit before the P52, so probably not long before this scenario. It comes with the message "PTC REFSMMAT".

The REFSMMAT is a rotation matrix (https://en.wikipedia.org/wiki/Rotation_matrix) and the AGC doesn't really have good protection against an uplinked REFSMMAT that isn't a rotation matrix. So that can lead to really weird behavior. Like, the AGC tries to convert a star UNIT vector from reference to sextant coordinates but because the resulting vector isn't a unit vector anymore bad things happen. For me in your scenario the computer was quite good at pointing the sextant at star 41, but rather bad with star 34. And if I mark on the actual stars the star difference angles wasn't close to zero. Weird things like that.

Anyway, something must have happened to the uplink. The MCC state seems to suggest that you already did the uplink. Did something go wrong with the uplink of that PTC REFSMMAT? Or did you maybe use the PAMFD or RTCC MFD to uplink a new state vector after that PTC REFSMMAT uplink? Because the AGC has a rather annoying "feature", any other type of uplink destroys the uplinked desired REFSMMAT.

You can recover fairly easily in this scenario I think. The CAPCOM menu of the MCC has the option to repeat an uplink. Just do that and the P52 option 1 should go well.
 

Paraso

Member
Joined
Nov 11, 2018
Messages
30
Reaction score
22
Points
8
Ok, I can replicate the behavior as you have described it. I think I know what causes it, the desired REFSMMAT stored in the computer is bad. The desired REFSMMAT is the REFSMMAT (https://en.wikipedia.org/wiki/REFSMMAT) that defines the IMU alignment after the P52 option 1. It replaces the current REFSMMAT during the P52. This desired REFSMMAT was uplinked a bit before the P52, so probably not long before this scenario. It comes with the message "PTC REFSMMAT".

The REFSMMAT is a rotation matrix (https://en.wikipedia.org/wiki/Rotation_matrix) and the AGC doesn't really have good protection against an uplinked REFSMMAT that isn't a rotation matrix. So that can lead to really weird behavior. Like, the AGC tries to convert a star UNIT vector from reference to sextant coordinates but because the resulting vector isn't a unit vector anymore bad things happen. For me in your scenario the computer was quite good at pointing the sextant at star 41, but rather bad with star 34. And if I mark on the actual stars the star difference angles wasn't close to zero. Weird things like that.

Anyway, something must have happened to the uplink. The MCC state seems to suggest that you already did the uplink. Did something go wrong with the uplink of that PTC REFSMMAT? Or did you maybe use the PAMFD or RTCC MFD to uplink a new state vector after that PTC REFSMMAT uplink? Because the AGC has a rather annoying "feature", any other type of uplink destroys the uplinked desired REFSMMAT.

You can recover fairly easily in this scenario I think. The CAPCOM menu of the MCC has the option to repeat an uplink. Just do that and the P52 option 1 should go well.
Hi!

So yes the uplink has already been done in that scenario, and I didn't mess with any of the MFD's . I loaded into an earlier save I had just before the uplink, and made sure that there was, for sure, no more uplink activity before I continued on in the checklist. Good news, when I got into the P52 option 1 after doing so, the SCT pointed at the stars with almost complete accuracy, and the star difference angles in the DSKY were below the threshold values. I think the issue was that previously, when I used the "ready for uplink" option in the mcc menu, I pressed pro on that item in the checklist rather than waiting for the uplink to complete, so that's my fault. I appreciate it Indy.

Just one question before I continue, when I'm in the part in the PTC checklist where I maneuver to ptc attitude, I usually have to press "pro" twice for the manuvering to begin rather than once as the checklist suggests. Is this an issue at all? Is this known?
 

indy91

Addon Developer
Addon Developer
Joined
Oct 26, 2011
Messages
994
Reaction score
288
Points
78
Just one question before I continue, when I'm in the part in the PTC checklist where I maneuver to ptc attitude, I usually have to press "pro" twice for the manuvering to begin rather than once as the checklist suggests. Is this an issue at all? Is this known?

Checklist MFD has it wrong, it's missing a PRO.
 

Paraso

Member
Joined
Nov 11, 2018
Messages
30
Reaction score
22
Points
8
I just finished LOI-1 without any issues at all. I cannot thank you enough for your help Indy, I greatly appreciate your time. Big thanks to everyone else who jumped in to help as well, I really appreciate it.
 
Top