Problem Energia Project Error Orbiter 2016

Kazindel

New member
Joined
Feb 7, 2020
Messages
8
Reaction score
1
Points
3
Location
United Kingdom
I have looked at many different ways to fix this issue. Two mentioned that it might have been the D3D9 graphics module (Using R4.26) and all the links that I tried to use are all missing.
Version of Orbiter: Orbiter Space Flight Simulator 2016 Edition (build 160828)
Following missing links:
http://www.orbiter-forum.com/showthread.php?t=37986
https://www.orbiter-forum.com/showthread.php?p=530479&postcount=3653 (Yes I did try and remove the "&postcount=3653" part)
Addons I have used for the log:
Energy Project (the addon I pressed on before crashing)
Buran Launch Complex High Detail Ver3 (BLCHDV3) (Runs fine)
Buran3.03BETA (Not sure if needed)
D3D9 for Orbiter 2016

The log appears below.
 

Attachments

  • Orbiter.log not tampered.txt
    8.9 KB · Views: 7
Last edited:

n72.75

Move slow and try not to break too much.
Orbiter Contributor
Addon Developer
Tutorial Publisher
Donator
Joined
Mar 21, 2008
Messages
2,704
Reaction score
1,378
Points
128
Location
Saco, ME
Website
mwhume.space
Preferred Pronouns
he/him
It looks like you have the right version of Energy Project, and D3D9 Client.

Which scenario were you trying to launch.

If you look in the log, these lines are a clue:

Code:
============================ ERROR: ===========================
Failed loading module Modules\Plugin\UMmuforOrbiter2016.dll (code 126)
[Orbiter::LoadModule | .\Orbiter.cpp | 600]
===============================================================

UMMU isn't compatible with Orbiter2016. Dan was working on updating UMMU, but he hasn't been active for a few years.

Do any of the scenerios load for you.

I will note: It looks like you have a bunch of addons installed. I would strongly recommend that you start with a fresh installation and work up from there.

Not all addons are created equal, and some have compatibility issues. I know this information isn't always super obvious. There is a good list of addon compatibility here, it's also a nice index.
 

Kazindel

New member
Joined
Feb 7, 2020
Messages
8
Reaction score
1
Points
3
Location
United Kingdom
Here's a box of logs. NEARLY all scenarios of the ENERGY project, but I see that they have a common trait of crashing around the "ENERGIA" loading phase. It seems that it really doesn't like the SHLLV that much. quite a common trait. The only working ones are the types that don't include the Energia SHLLV. With that, I did go on to a random scenario then used the Scenario editor to place the SHLLV and it resulted in a crash. But please, I would love a second opinion. Take a look.

28 minutes later edit: I just noticed "I will note: It looks like you have a bunch of addons installed. I would strongly recommend that you start with a fresh installation and work up from there."

P.S. I removed the 'UMMU for Orbiter 2016' plugin. (Even though It still for some reason appears still. Quite odd)
Below are all the plugins I use, and yes I did remove UMMU for Orbiter 2016 before opening the scenarios.
ALL plugins I use.png.
 

Attachments

  • Energy project logs.zip
    20.3 KB · Views: 0
Last edited:
Top