Spacecraft Soyuz 7K for Orbiter 2016

Gargantua2024

The Desktop Orbinaut
Joined
Oct 14, 2016
Messages
781
Reaction score
907
Points
108
Location
San Jose Del Monte, Bulacan
Of course, this is only usable for Soyuz for now, as my latest Proton update still suffers from third-party attachment bug. (older Proton by Thorton should be used until then). But once I get to update it, same trick will work for the new Proton (for any VesselM family addon, in fact).
You're right. Creating a custom SoyuzMissions.cfg file is better than directly overwriting the original source file. I will move the changes in the cfg into its own file on the next release. Meanwhile, as I reinstalled everything I just also confirmed your prior findings that Soyuz version 1.3 does not support third-party payloads like this addon (why didn't I notice I'm using version 1.2 all along lol).

In the Proton addon, version 3.1 also does not support third-party payloads, but version 3.0 (the March 2021 edition) does. In summary, just like your conclusions, all the recent bugs reported in this thread since Post 43 are caused simply by addon version incompatibility. I hope this solves all the issues reported, and I'm truly sorry for the inconvenience
 

igel

Addon Developer
Joined
Mar 28, 2008
Messages
252
Reaction score
118
Points
43
Website
www.pin-plus.ca
Good news, thanks! I'll also now be more cautious with new releases, knowing they are directly used in other popular addons. With such mass of code and files, I long ago rely on automated testing, and it mostly keeps quality at pretty good. But even automation won't help if there is no test case for a particular situation. It will be now! :).
 

MaxBuzz

Well-known member
Joined
Sep 19, 2016
Messages
817
Reaction score
1,199
Points
108
Location
Kursk
I already have it enabled, that's the problem.
trench in development igel
 

igel

Addon Developer
Joined
Mar 28, 2008
Messages
252
Reaction score
118
Points
43
Website
www.pin-plus.ca
Hm. Very very strange... What do you have for second elevation-related option? This one:
1641432487286.png
For some reason (don't remember what was happening) it did not work with other settings of this dropdown. I can't check it myself at the moment, not till weekend at least...
 

GEMINIDUDE44

New member
Joined
Oct 16, 2020
Messages
17
Reaction score
0
Points
1
Location
NO
Hi everyone ! so i installed everything for the Soyuz 7k mod but when i start a scenario it crashes the game...
I will put my Orbiter.log


Thanks for helping !



**** Orbiter.log
000000.000: Build Aug 28 2016 [v.160828]
000000.000: Timer precision: 1e-007 sec
000000.000: Found 1 joystick(s)
000000.000: Module AtlantisConfig.dll .... [Build 160828, API 160828]
000000.000: Module AtmConfig.dll ......... [Build 160828, API 160828]
000000.000: Module DGConfigurator.dll .... [Build 160828, API 160828]
000000.000: ---------------------------------------------------------------
BaseDir : D:\Orbiter 2016\
ConfigDir : D:\Orbiter 2016\Config\
MeshDir : D:\Orbiter 2016\Meshes\
TextureDir : D:\Orbiter 2016\Textures\
HightexDir : D:\Orbiter 2016\Textures2\
ScenarioDir: D:\Orbiter 2016\Scenarios\
000000.000: ---------------------------------------------------------------
D3D9 DLLs : C:\WINDOWS\SYSTEM32\d3d9.dll [v 10.0.22000.120]
: C:\WINDOWS\SYSTEM32\d3dx9_43.dll [v 9.29.952.3111]
000000.000: ---------------------------------------------------------------
000000.000: Module D3D9Client.dll ........ [Build 210805, API 160828]
000000.000: Module Meshdebug.dll ......... [Build 160828, API 160828]
000000.000: Module TrackIR.dll ........... [Build 160828, API 160828]
000000.000: TrackIR module not found.
000000.000: Module CustomMFD.dll ......... [Build 160828, API 160828]
000000.000: Module GenericCamera.dll ..... [Build 210805, API 160828]
000000.000: Module LuaMFD.dll ............ [Build 160828, API 160828]
000000.000: Module transx.dll ............ [Build 160216, API 160214]
000000.000: Module InterMFD57.dll ........ [Build 161216, API 160910]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: oapiRegisterMFDMode
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
000000.000: Module LunarTransferMFD.dll .. [Build 160829, API 160815]
000000.000: Module LuaConsole.dll ........ [Build 160828, API 160828]
000000.000: Module ScriptMFD.dll ......... [Build 160828, API 160828]
000000.000: Module DX9ExtMFD.dll ......... [Build 210805, API 160828]
000000.000: Module ExtMFD.dll ............ [Build 160828, API 160828]
000000.000: Module FlightData.dll ........ [Build 160828, API 160828]
000000.000: Module Framerate.dll ......... [Build 160828, API 160828]
000000.000: Module Rcontrol.dll .......... [Build 160828, API 160828]
000000.000: Module ScnEditor.dll ......... [Build 160828, API 160828]
000000.000: Module Multistage2015_MFD.dll [Build 170506, API 160828]
000000.000:
000000.000: **** Creating simulation session
000000.000: D3D9: [DirectX 9 Initialized]
D3D9: 3D-Adapter.............. : NVIDIA GeForce GTX 1660
D3D9: MaxTextureWidth......... : 16384
D3D9: MaxTextureHeight........ : 16384
D3D9: MaxTextureRepeat........ : 8192
D3D9: VolTexAddressCaps....... : 0x3F
D3D9: NumSimultaneousRTs...... : 4
D3D9: VertexDeclCaps.......... : 0x30F
D3D9: MiscCaps................ : 0x2FCEF2
D3D9: XNA Math Support........ : Yes
D3D9: Vertex Texture.......... : Yes
D3D9: Separate AlphaBlend..... : Yes
D3D9: Shadow Mapping.......... : Yes
D3D9: D3DFMT_A16B16G16R16F.... : Yes
D3D9: D3DFMT_A32B32G32R32F.... : Yes
D3D9: D3DFMT_D32F_LOCKABLE.... : Yes
D3D9: D3DFMT_A2R10G10B10...... : Yes
D3D9: D3DFMT_L8............... : Yes
D3D9: D3DDTCAPS_DEC3N......... : No
D3D9: D3DDTCAPS_FLOAT16_2..... : Yes
D3D9: D3DDTCAPS_FLOAT16_4..... : Yes
D3D9: Runs under WINE......... : No
D3D9: D3D9Build Date.......... : 210805
D3D9: Available Texture Memory : 4080 MB
000000.000: D3D9: [3DDevice Initialized]
000000.000: D3D9: [Loading Constellations]
000000.000: D3D9: [D3D9Client Initialized]
000000.000: Module Sun.dll ............... [Build 160828, API 160828]
VSOP87(E) Sun: Precision 1e-006, Terms 554/6634
000000.000: Module Earth.dll ............. [Build 160828, API 160828]
000000.000: Module EarthAtmJ71G.dll ...... [Build 160828, API 160828]
VSOP87(B) Earth: Precision 1e-008, Terms 2564/2564
000000.000: Module Moon.dll .............. [Build 160828, API 160828]
ELP82: Precision 1e-005, Terms 116/829
000000.000: Finished initialising world
000000.000: Module VesselBuilder1.dll .... [Build 190415, API 160828]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: VESSEL::SetBankMomentScale
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
000000.000: Finished initialising status
000000.000: Finished initialising camera
000000.000: Finished setting up render state
D3D9: ERROR: Base Object 0x34AB748 = 'Baikonur_1' not cataloged
D3D9: ERROR: Base Object 0x34ABAB8 = 'Baikonur_2' not cataloged
D3D9: ERROR: Base Object 0x349B058 = 'Baikonur-51' not cataloged
D3D9: ERROR: Base Object 0x34ABE28 = 'Baikonur_51' not cataloged
D3D9: ERROR: Base Object 0x34AC198 = 'Baikonur-70' not cataloged
D3D9: ERROR: Base Object 0x34AC508 = 'Baikonur_70' not cataloged
D3D9: ERROR: Base Object 0x34BAFE0 = 'Baikonur-23' not cataloged
D3D9: ERROR: Base Object 0x34B1708 = 'Baikonur_23' not cataloged
D3D9: ERROR: Base Object 0x34B1A78 = 'Baikonur-24' not cataloged
D3D9: ERROR: Base Object 0x34B1DE8 = 'Baikonur_24' not cataloged
D3D9: ERROR: Base Object 0x34B2158 = 'Baikonur_81' not cataloged
D3D9: ERROR: Base Object 0x34BD7F8 = 'Baikonur-31' not cataloged
D3D9: ERROR: Base Object 0x34BDB68 = 'Baikonur_31' not cataloged
D3D9: ERROR: Base Object 0x34BDED8 = 'Baikonur_112' not cataloged
D3D9: ERROR: Base Object 0x34BE248 = 'Baikonur' not cataloged
D3D9: ERROR: Base Object 0x34BE5B8 = 'Arkalyk' not cataloged
D3D9: ERROR: Base Object 0x34CD178 = 'Dzezkazgan' not cataloged
000000.000: D3D9: [Scene Initialized]
000000.000: ---------------------------------------------------------------
000000.000: >>> WARNING: Obsolete API function used: oapiGetAtmPressureDensity
000000.000: At least one active module is accessing an obsolete interface function.
000000.000: Addons which rely on obsolete functions may not be compatible with
000000.000: future versions of Orbiter.
000000.000: ---------------------------------------------------------------
 

N_Molson

Addon Developer
Addon Developer
Donator
Joined
Mar 5, 2010
Messages
8,651
Reaction score
2,267
Points
203
Location
Toulouse
There's something wrong with the surface base, or "scenery" as you'd say in MSFS, things are missing. It looks like there are no errors related to the rocket/spacecraft themselves, though.
 

GEMINIDUDE44

New member
Joined
Oct 16, 2020
Messages
17
Reaction score
0
Points
1
Location
NO
There's something wrong with the surface base, or "scenery" as you'd say in MSFS, things are missing. It looks like there are no errors related to the rocket/spacecraft themselves, though.
And is there a way to fix it ?
 

diogom

Well-known member
Joined
Aug 2, 2010
Messages
1,210
Reaction score
107
Points
78
Are you using the Soyuz 1.3 launcher?
 

diogom

Well-known member
Joined
Aug 2, 2010
Messages
1,210
Reaction score
107
Points
78
No im using the 1.2 Version
Hm. And VesselBuilder installed too, right? By the way, the "'Baikonur' not cataloged" stuff is weird but it happens for me even on working scenarios. Other than that, not sure.
 
Top