Problem Sucky frame rate under Linux

TMac3000

Evil Republican
Joined
Nov 16, 2008
Messages
2,773
Reaction score
0
Points
36
Location
Flying an air liner to the moon
Posted this in the RCT, thought I might get more help if I post it here:

Just a couple of days ago, I downloaded and installed Orbiter under Linux. You can imagine my surprise when it ran right out of the box in Wine, with no Winetricks, or having to download any obscure software or type any arcane commands :blink::woohoo:

But naturally, there was a catch: a 5 FPS frame rate :facepalm:

Now, that frame rate IS semi-playable for the patient soul who has been to Mercury and back in real time :) , but it makes docking a total pain.

I have removed ALL the eye-candy. I have tried every resolution except a UN resolution :p, and all the different devices listed (Direct 3D HAL, D3D HAL Wine, etc). 5 FPS is simply the max I can seem to get.

Here are my specs:

IBM Lenovo Desktop, 3.5 GHz, 2 Gb RAM, Intel Graphics running Open GL 1.4 Mesa
Kubuntu 14.04 32-bit, Wine 1.6.2
Orbiter 2010 P1, no mods (I'm not getting any until I figure this out)

I'm really starting to think it's just my hardware. I really hate to think this is gonna take money to fix :(
 

mjanicki

Addon Developer
Addon Developer
Donator
Joined
Apr 4, 2008
Messages
106
Reaction score
0
Points
0
Location
Spokane
Hi, Tmac.

Orbiter 2010 under Wine (on a Slackware box) was the same for me until I found out that wine wasn't using OpenGL for rendering. For me, I had to add a couple of registry entries (wine regedit). Specifically I needed to add a key for DirectDrawRenderer and UseGLSL.

Have a look at these useful registry keys for wine, notably the Direct3D section. With some of those keys I went from 11 fps to 125 fps.

If your problem isn't resolved by editing the registry, then hopefully someone who knows more about video will come along. :)

-- Mike
 

TMac3000

Evil Republican
Joined
Nov 16, 2008
Messages
2,773
Reaction score
0
Points
36
Location
Flying an air liner to the moon
Okay, I tried adding the registry keys for OpenGL--it didn't change anything.

Then I tried adding -opengl as an option in the command shortcut. That made Orbiter completely freak out and be unplayble, so I had to remove the option, which sent me back to sqaure one :(

Obviously I have OpenGL on my computer, because it shows up in the Graphics info under KSysInfo...

But how do I get Orbiter to use it?
 

mjanicki

Addon Developer
Addon Developer
Donator
Joined
Apr 4, 2008
Messages
106
Reaction score
0
Points
0
Location
Spokane
Oh well, it was worth a shot that it would be the easy fix. :)

I probably won't be of much help beyond this, but I can help you gather some info that might be useful to others to help troubleshoot. First, let's make sure that direct rendering is being made available. At a command prompt type:
Code:
glxinfo | grep -i render
and include the output in a reply. If the first line of that output is not "direct rendering: Yes" then you're not using direct rendering for anything, let alone Orbiter and your problem lies in general system video configuration.

If that looks ok, let's grab your OpenGL, Mesa, etc. info for other troubleshooters to help out. Type:
Code:
glxinfo |grep -i opengl
and include that in a reply.

And, the last bit I can contribute is that on my box (again, not Ubuntu so I don't know what your distro's setup looks like) I needed to make an adjustment or two through driconf. If your system has/uses driconf then you may want to have a look at the setting there. For me, one that makes a lot of difference is "Enable S3TC texture compression even if software support is not available" set to Yes.

Hopefully something in the 'glixinfo' output will provide something to go on.

-- Mike
 

TMac3000

Evil Republican
Joined
Nov 16, 2008
Messages
2,773
Reaction score
0
Points
36
Location
Flying an air liner to the moon
glxinfo | grep -i render
Here is the output
Code:
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
OpenGL renderer string: Mesa DRI Intel(R) 945G x86/MMX/SSE2

and for the other command:
Code:
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) 945G x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 10.1.3
OpenGL extensions:

Okay, so I'm obviously using OpenGL, the problem is just that I have no idea what I'm doing :lol:
 
Last edited:

mjanicki

Addon Developer
Addon Developer
Donator
Joined
Apr 4, 2008
Messages
106
Reaction score
0
Points
0
Location
Spokane
Well, at least direct rendering is working, but I don't see anything abnormal in your OpenGL info. Hopefully someone more familiar with video internals will come along, as I was able to get good performance with just the couple of changes already mentioned.

Only other thing I can think that we didn't cover is that I'm using the D3D9 client for Orbiter. Are you also, or are you using stock? If you are, perhaps try the D3D9 and see if it's any better.

Either way, hang in there and hopefully someone else might have some ideas.

-- Mike
 

TMac3000

Evil Republican
Joined
Nov 16, 2008
Messages
2,773
Reaction score
0
Points
36
Location
Flying an air liner to the moon
Installed the OGLA Client--I now get 20 FPS :thumbup:

Now if I can just figure out how to stop that blue flicker...

---------- Post added at 01:29 PM ---------- Previous post was at 08:58 AM ----------

But now I'm getting about half a dozen of these in ogla.log:
Code:
10/19/2014-10:36:23 AM:[OGLAUX    ]:Error: (ogla_render2D) Access violation at address 01133C93 in module 'ogla.dll'. Write of address 00000001 (hc=0)
and the screen flickers really bad. What can this mean?
 

BruceJohnJennerLawso

Dread Lord of the Idiots
Addon Developer
Joined
Apr 14, 2012
Messages
2,585
Reaction score
0
Points
36
Installed the OGLA Client--I now get 20 FPS :thumbup:

Now if I can just figure out how to stop that blue flicker...

---------- Post added at 01:29 PM ---------- Previous post was at 08:58 AM ----------

But now I'm getting about half a dozen of these in ogla.log:
Code:
10/19/2014-10:36:23 AM:[OGLAUX    ]:Error: (ogla_render2D) Access violation at address 01133C93 in module 'ogla.dll'. Write of address 00000001 (hc=0)
and the screen flickers really bad. What can this mean?

OGLA was never finished and at least a bit unstable in its last iteration as far as I know. I had a few intermittent stability issues with it when I tried it out.
 

TMac3000

Evil Republican
Joined
Nov 16, 2008
Messages
2,773
Reaction score
0
Points
36
Location
Flying an air liner to the moon
Never mind...all I needed was a Winetricks command I found in the OGLA release thread. It works beautifully now:thumbup:

That's what I get for trying to run Oribter in Linux without Winetricks--smacked by the Probe:lol:
 

Matias Saibene

Well-known member
Joined
Jul 7, 2012
Messages
798
Reaction score
300
Points
63
Location
Monte Hermoso - Argentina
Website
de-todo-un-poco-computacion-e-ideas.blogspot.com.ar
I have opened a thread where I publish my test results of Orbiter in Linux, with some recommendations. I reached up to 60-70 fps. Perhaps you serve.
:tiphat:

http://www.orbiter-forum.com/showthread.php?t=32835

Hi, Tmac.

Orbiter 2010 under Wine (on a Slackware box) was the same for me until I found out that wine wasn't using OpenGL for rendering. For me, I had to add a couple of registry entries (wine regedit). Specifically I needed to add a key for DirectDrawRenderer and UseGLSL.

Have a look at these useful registry keys for wine, notably the Direct3D section. With some of those keys I went from 11 fps to 125 fps.

If your problem isn't resolved by editing the registry, then hopefully someone who knows more about video will come along. :)

-- Mike

Sounds very interesting, I'll try.
 
Top